Mechanical chime not working with video doorbell pro 2

Just installed a Video Doorbell Pro 2 and upgraded my doorbell transformer to a 16V30VAC transformer (https://www.amazon.com/dp/B07GND8RMQ?psc=1&ref=ppx_yo2ov_dt_b_product_details). I am using the pro power kit which came with the device.

My ring doorbell says its getting 16V and is power level 1 with no issues. However, when I press my bell, the mechanical chime just buzzes. I checked the voltage at the transformer and I’m getting 18-19 V. All the connections seem OK. Any ideas on where to go from here? Thanks!

EDIT: Getting a current at the Chime without the button being pressed and a draw of 6V when the button is pressed. Is this a chime issue?

Hi @user21092uu. If your pre-existing chime is not working correctly with your Pro 2, you can use our compatibility list to make sure it is compatible with the Pro 2. If that checks out, you will also want to look into the In-home Chime Setting for your Pro 2 and verify that the settings look correct. To do so, follow these steps:

  • Open Ring app
  • Select the menu button (three lines, top left).
  • Tap Devices
  • Select your Pro 2
  • Tap Device Settings
  • Select In-home Chime Settings.
  • Check that the chime is set to mechanical rather than digital.

If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.