MacOS Sonoma Desktop Notifications won't work, says ring.com blocking notification

I have tried to find a place where this is “supposedly” blocked but can’t find anything. Safari for Mac also has no setting to ADD Ring to websites, the Browser has to ask if I can add or not. I am stuck. Anyone else having this issue lately? Desktop Notifications work fine on Firefox for Mac.

Hi @sandyfl. This Help Center article here has information on how to correct this. If you are still having issues, please follow up with our support team. You can also get in touch by sending a private message @Ring on Facebook or Twitter.

Hi Tom, I tried all of this previously and again now.

You can see the Error Message at the top of the page shot, says that there is a setting in Safari. That is what I have been trying to find. BTW, this is not an issue with Firefox for Mac, only Safari for Mac.

I was hoping that Safari would simply “ask” if I want to give permission to enable notifications, but it does not. Therefore, I can’t add the Ring URL in approved web app notifications.

Hopefully someone will know the workaround for Safari for Mac, using current Version, Version 17.4 (19618.1.15.11.12)

Thanks,

Sandy

Hi @sandyfl. Try this: Click on the “Safari” menu in the top left corner of your screen and select “Preferences.” Click on the “Websites” tab at the top of the window. Scroll down to the “Notifications” section and click on the website you want to receive notifications from. If that does not work, I’d suggest following up with our support team.

1 Like