MacOS App Preventing Sleep

My computer would just refuse to sleep sometimes, with no apparent rhyme or reason. I tracked it down to the Ring MacOS app. Specifically, it seems that when I start a live view, the app prevents sleep and doesn’t toggle back after the live view is closed.

When viewing a recording, the app also prevents sleep, but toggles back when the video is closed. This is the expected behavior.

See the attached screenshot from Activity Monitor showing the “Preventing Sleep” state

Screen Shot 2019-10-15 at 12.43.44 AM.png

1 Like

Thank you for this feedback @bchavet ! Can you please confirm the Ring app version you are using, and what software version your Mac is currently running?

MacOS: 10.14.6 (Mojave)

Ring: Version 2.3.0 (735)

Same problem here with 10.15 and Ring 2.3.0

Thanks for this information, neighbors! We have shared it with the team for further review.

Same problem with Ring App 2.4 and Mac OS 10.14.6

HI, same problem here. Seems it should be a relatively simple fix hopefully. I would definitely use the app more often if it allowed my iMac to sleep. I’m on 10.15.2. Ring version : 2.4.0 (745)

I really hope Ring will address this problems soon as it’s preventing me from enjoying the otherwise really great app.

Many thanks.

1 Like

I’m having the same issue.

Ring App Version: 2.4.0

macOS Version: 10.15.1

I have contacted Ring Support and had half a dozen rounds of communication with them. They keep telling me that this is a setting in the operating system and to “contact MAC support” (whatever that means). I’ve asked several times for them to forward the problem report on to the Ring development team to look at, but they won’t do it. Very frustrating.

This is most definintely not an operating system setting. This is the Ring app requesting that the operating system not go to sleep while it is doing something. It makes sense for this to happen while Ring is playing a video, but it needs to be turned back off when the video playback stops.

Here are some technical details:

bchavet@trouble ~ $ pmset -g assertions 2020-01-18 13:17:37 -0600 Assertion status system-wide: BackgroundTask 0 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 1 PreventSystemSleep 1 ExternalMedia 0 InternalPreventDisplaySleep 1 PreventUserIdleSystemSleep 1 NetworkClientActive 0 Listed by owning process: pid 220(coreaudiod): [0x00041a3800019c2e] 00:03:03 PreventUserIdleSystemSleep named: "{AC10-A0EC-3045354C}.context.preventuseridlesleep" Created for PID: 39619. pid 220(coreaudiod): [0x00041a3800059c2f] 00:03:03 PreventUserIdleDisplaySleep named: "{AC10-A0EC-3045354C}.context.preventuseridledisplaysleep" Created for PID: 39619. pid 125(powerd): [0x00041a3800108002] 00:03:03 InternalPreventDisplaySleep named: "" Timeout will fire in 116 secs Action=TimeoutActionTurnOff pid 173(hidd): [0x000419a700099ba2] 00:00:00 UserIsActive named: " serviceID:1000044a2 name:AppleHIDKeyboardEve product:Magic Keyboard with eventType:3" Timeout will fire in 600 secs Action=TimeoutActionRelease [...snip...] Idle sleep preventers: IODisplayWrangler
bchavet@trouble ~ $ ps up 39619 USER PID %CPU %MEM VSZ RSS TT STAT STARTED TIME COMMAND bchavet 39619 1.2 0.6 5056276 104836 ?? S 1:13PM 0:06.54 /Applications/

As you can see, the PreventUserIdleSystemSleep and PreventUserIdleDisplaySleep flags are set at the request of PID 39619. That PID belongs to the Ring app.

I’m not a MacOS App developer, and this took me all of five minutes to track down. I’m sure Apple provides plenty of API documentation around this, and it is clearly unintentional behavior on Ring’s part.

Bugs happen. How they are handled is what matters. This is disappointing.


Yep, that was the result of my research and my conclusion as well.

Considering how every update to the macOS and iOS Ring Apps includes a request that you submit bugs and feature ideas to the development team by emailing, I figured this would be a simple case of informing them of the bug so they could fix it.

I’ve now had 10 emails back and forth with Ring Support over this issue and they are refusing to escalate it, insisting that I need to contact “MAC support” (whatever that means). Very disappointing, but in line with my previous support experiences with Ring.

It means it’s a Mac issue. Call Apple.

"It means it’s a Mac issue. Call Apple. "

That would be a fine answer if it were a Mac issue that Apple could potentially help with. It’s not. Refer to bchavet’s troubleshooting two posts up, or go Google it yourself. The Ring app is specifically instructing macOS not to sleep. It’s not a problem with the OS; it’s a problem with the Ring app.

I don’t own anything from Apple. But I answered your question…
I’ve now had 10 emails back and forth with Ring Support over this issue and they are refusing to escalate it, insisting that I need to contact “MAC support” (whatever that means).

This is not an MacOS issue, no other app causes this issue. There’s actually no point in this app existing the way it is on Mac, the designers have just wasted their time and Ring have wasted their cash on it.

Until this issue is fixed the app is 100% useless.

Hey neighbors! Thank you for bringing this to our attention and putting in more effort to dissect this concern further. At this time our team is aware of this concern and is working on a fix.

For now, I have accepted this post as a solution. While we are aware of this concern and the team continues to investigate, this is a helpful way for other neighbors that come into this thread to try these recommended troubleshooting steps discussed between other neighbors. If these troubleshooting steps do not work, please share in depth information and examples as to what happens so we can pass it along to the appropriate teams. We appreciate your patience and will continue to update this thread with more information once available. Thank you.

Still preventing sleep on latest mac app store update Version 2.5.1 (761).

When will this be fixed? This app is useless on a Mac still. If every Ring customer was actually made aware of this issue, not one single user would be inclined to download this on a Mac.

Fix. The. Issue…

Thanks for your patience neighbors! After checking in with my team on this concern, it looks like they are in the final steps to get this resolved with a fix to push out soon. They’ve recommend to check the following to see if you change your settings manually (if not, it’ll be fixed once we have the solution deployed in a future app update):

  • Open Activity Monitor
  • Go to Energy Tab -> look “Preventing Sleep”
  • Should see Ring app as “YES,” see if you can change this to NO so that it does not prevent sleep

I personally was not able to make these changes, but wanted to see if you neighbors could! If you cannot, no worries, rest assured I will make sure to keep you all updated once this is fully addressed. :slight_smile:

There is no option to change the “prevent sleep” setting in Activity Monitor. That’s because it’s not a setting and Activity Monitor is not a settings panel, it’s an activity monitor. This is the same advice I got from Ring Support and it’s simply wrong. The Activity Monitor tells you what’s happening, and what’s happening is that the Ring app is preventing the OS from going to sleep.

Please make sure that your team knows that there is no working fix available for this problem. We need for the app to be fixed.

after hearing this advice, I am quite worried about the development teams understanding of how macOS works.

@pallen Thank you for this information! My team had acknowledged to me that this is where a neighbor can see if they are having the Ring app prevent the sleep or not, and wanted to verify what it was saying for the neighbors on your end. Sorry for any confusion from my last post! Neighbors, if you can also, please provide me the following to pass onto the teams:

  • Mac OS version
  • Ring app version
  • Type of Mac computer you have (MacBook Air, Pro, etc.)

Thanks neighbors! I’ll make sure to keep you updated once we have a fix for this. :slight_smile: