Lost Owner Account

So I got a ring doorbell 2 February of this year and it worked perfectly fine until 2 days ago when I was logged out. I never received any kind of email of a password change or an unusual login, but I was logged out and I couldn’t login. So I requested a password change but never received the email. After this couldn’t seem to get anything to work, so I went ahead and made a new account (with the same email that I originally used) and tried setting my ring up, but it requested owner permission, which comes from the same email which I cannot log into. So is there a way to factory reset, or remove the ring device from the original owner? I also still have the verification email from February if that helps.

Hey @CN8888. To get this concern addressed, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.