Lost Connection to Doorbell

I have a Ring Doorbell 3, hardwired. It was working for over a year, no problems at all. All of a sudden, it now shows that it cannot connect to wifi. When I tried to connect it by pressing the orange button on the front of the device, the instructions say wait for the circle light around the button to flash. The problem is that there’s no light at all.

When idle, there’s no blue or white ring circle around the button.
When I press the button, there’s no flash or activity, however it DOES ring inside the house to the hardwired chime box.

Any ideas?

Thanks.

Hi @FluffyCorgi. Did you charge the battery prior to setup? Even with the Ring Doorbell 3 being hardwired, you still may need to charge the battery. This is because the hardwiring provides a trickle charge to the battery and does not serve as a primary power source, as noted in this Help Center article here.

Once you’ve verified that your battery is fully charged, you can perform a reset by pressing and holding the setup button for 20 seconds, then release. This should allow your Doorbell to enter Setup Mode. Let me know if this helps!