Location to toggle Legacy Video

I can’t find the location in the Ring app to toggle Legacy video. I’ve tried looking the setting by logging in through Ring.com website. The Ring desktop app for some reason won’t let me log in, and it looks like it’s no longer available.

I’m sure there’s someone smarter who has the answer. Please share. I’m sure I’m not the only one.

Hi @user49675. The Ring desktop app has been discontinued as of June 1, 2023. If your mobile device doesn’t support High-Efficiency Video Compression (HEVC), you can turn on Legacy Video Mode under Device Settings > Video Settings. This will be an option on the following Ring devices:

  • Stick Up Cam Plug-in
  • Stick Up Cam Battery
  • Ring Video Doorbell (2nd Generation)
  • Floodlight Cam Wired Plus

I’ve gone to Devices>Security Cameras>Selected the camera (it’s the only one)>Device Settings>Video Settings. The option for Legacy Video Mode is not there. Where else should I look?

I’m using version 5.61.0 of the Ring app for iPhone.

I’ve gone to Devices>Security Cameras>Selected the camera (it’s the only one)>Device Settings>Video Settings.

The option for Legacy Video Mode is not there. Where else should I look?

@user49675 Which model of Camera is this? The model name is located on the Device Health page and on the original packaging.

It’s for the Stick Up Cam Battery (3rd Gen)

Hey! I have Spotlight Cam Plus which I need to switch to Legacy Video mode, but the toggle is not there (iPhone Ring app). What should I do?

Ring, if there is no switch to return it to Legacy Video mode, I can throw out my 2 cameras, as it renders my cameras useless as I rely on Homebridge to view them in Homekit.

1 Like

I’m glad I’m not the only one who’s convinced they are not blind or stupid because they can’t find that feature.

Ring - Please put back that feature.

Nick - Don’t throw throw away your cameras. It’s got to be a software issue. I’m sure other Ring cameras are also affected.

If you have one of the devices listed in my previous reply, and do not see the Legacy Video Mode toggle, please follow up with our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

Thats a different device. Do you plan to allow Legacy mode on these?

I have the Ring Video Doorbell (2nd Generation) and do not see this option in the app as my phone supports HEVC. Is there a way to enable this option anyways since I prefer to use it for maximum compatibility with other devices that don’t have access to the app?

I’m so done with Ring, ffs we pay a monthly fee only to have cameras that become useless because Ring refuses to allow HomeKit. Using Homebridge was working fine not the stick up camera doesn’t even have an option for “legacy mode” time to save my $15 per month and just buy some HomeKit cameras.

1 Like

Hi @Caitlyn_Ring, I have a Ring Video Doorbell (2nd Generation) and do not see the video toggle. When I called in to support, they claimed to know nothing about the Legacy Video Mode and said that it was not a feature anywhere within the app.

How should I go about turning it on?

Hi Same issue here. The option is not available in the app. I have the cameras that support legacy mode. Why was the option removed?

We are having the same issue with just one of our cameras. We are starting to look at other camera brands now because it is just problem after problem with these Ring cameras. As soon as one issued is resolved a new issue pops up. What good are these cameras if you can’t view the recording and the steps they tell you to use don’t work? And why is only 1 of them having this issue??? Get us a resolution!

I’ve logged in to the Ring website in hopes that I’d find the elusive Legacy Video Mode switch and I still haven’t found it. Even through a web browser, I am unable to view the video stream thus confirming what other users’ complaints.

The link to the support article discussing the problem now points to some support start page but not the article. That article even though it contained broken links to the pictures, was still available just a week ago. Is Ring trying to whitewash/erase t/deny that this problem even exists?

I have a Ring Stick-up Cam. I’ve had it for 7 1/2 months, and it has worked fine without any problems.

Yesterday, the past month’s worth of recorded videos suddenly became unplayable in Firefox. “Video was recorded using a modern HEVC video format called that is not supported on this browser.”

After talking with customer support for a little bit, it was determined that it’s a Firefox issue.

So I went to the Firefox community for answers. That conversation is still in progress.

The response so far is that windows media foundation usually decodes encoded stuff for playback, but if that was acting up I’d probably notice playback issues elsewhere, and a link to a thread where switching to legacy mode was the only solution anybody came up with so far.

I have found the legacy mode thing, and newer recordings seem to be working. That doesn’t really explain though, what the problem is, and how to fix it. It seems like the explanation is that there is basically a compatibility issue between the way some Ring products record their videos, and Firefox’s playback options. The problem I have with that is everything was fine for 7 months. The issue only showed up 24 hours ago.

So I’m trying to figure out what changed, and what I might try to do to fix it.

Ring says it’s a Firefox issue, Firefox says it’s a Ring issue, and nobody seems to be able to give me a solution.

Is there anybody else who has encountered this and has come up with a fix for it.

I ran into this today on the Ring website and discovered that when I clicked on the “Learn more” shown there I got an option to turn legacy mode. I was going to go back and take a screenshot but now I find that the “Learn more” on older videos with this issue just takes me to the support site and not a way to toggle it again. :person_shrugging:

Ring are not covering themselves in glory with how they’re handling this. If you’re going to direct people to a setting do make sure it exists before you do so. Also don’t go changing your users device settings without getting them to confirm the change first.

HVEC is a patent encumbered format and so it’s a problematic format for widespread browser support (for instance Firefox won’t support it at present). My feeling is that it’s probably better for their customers experience if Ring to default to the previous supported format and let people opt in (and out) of HVEC should they wish to.

1 Like

same here - can’t use with homebridge… bring back the Legacy Mode toggle!!!