Live View not working

Either when I receive a ring at the doorbell, or if I try to view the live feed from my front door, I get Activating Device… I am able to watch the video feeds later via the Ring app, but not the live feed.

I’ve read the suggestions on here. I updated my home wireless to Amplifi HD, which is excellent, and still getting “Activating Device…”

Is my device defective, or is there some secret setting for my wireless that needs to be changed?

Hi @dplong ! Ready for the weekend? Are you using a cell phone or your computer to pull up Live View?

I have this same issue. I am trying to access liveview on my phone. I have been through the checks and my signal strength is excellent, download and upload are both over 3 and my RSSI green at -50. Please help.

Same here.

Hey neighbors! Please note that your Live View can be affected by many different factors, and therefore while multiple people may have a concern with Live View, you all could be having this concern for different reasons. Live View is normally affected from a poor wifi connection, reduction in upload speeds (or download, but upload is more common with Live View, and upload is normally much less than download available from your ISP if you do a speed test), low battery on the device, a high RSSI value, interference from the router, or the wifi connection in the home being used elsewhere (kids, family, friends or roommate using the internet or working from home). If you are experiencing more concerns than just Live View, you can try the steps, but it may be best handled with our support team if your device is not functioning as it should. Below I will list out all possible options you can try! I’ve collected this from other neighbors and my own personal experience. :slight_smile:

Some neighbors have found relief to this concern by doing the following to their network:

  • Switching networks for the device, whether this is from 2.4 Ghz to 5.0 Ghz (if possible for device/network to connect to)
  • Switching from connection to a router to a mesh system/Chime Pro/extenders and vice versa
  • Rebooting your router, ensuring that all ports and protocols are opened for the Ring devices
  • Ensuring you have proper speeds. Lots of neighbors during this time have noticed slower speeds because of the current conditions and changes to at home life
  • Disabling any VPNs

Some neighbors have found relief in this concern by doing the following to their Ring device:

  • Completely reset the device by pressing and holding the setup button for 30 seconds
  • Removing the device (after saving any recordings you may need) and then re-setting the device up
  • Testing Live View with device next to the router
  • Ensuring device is fully charged
  • Looking at Device Health and confirming RSSI is in acceptable range

Some neighbors have found relief in this concern by doing the following to their app:

  • Disabling VPNs on the phone
  • Removing the app, rebooting phone, reinstalling the Ring app
  • Trying the Rapid Ring app
  • Connecting to the app on wifi or mobile data only (testing whichever connection is not your normal)
  • Updating app/OS software on phone

Please note that if you do not feel comfortable enough preforming any of these troubleshooting steps to see if you can get your Live View working again, you can always contact our support team directly. They can take a look into your account and device to determine what is really going on, and what factor may be at play here. Please feel free to come back to this thread and post your solutions that you have found for Live View! For support, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Let’s get the issue fixed with iOS 13.5.1 and then we can start talking. There is a big issue but it seems like it’s not being discussed.

1 Like

When viewing live view are you on an iOs device or android?

Android, Samsung Note 8

Android cell phone, Samsung Note 8. It just says Activating Device…

It doesn’t work even if I’m at home using the Wifi.

This may be different than the issue that I’m experiencing. I have apple devices that I recently updated to iOS 13.5.1 and Live View no longer worked after the update but works on devices with the older iOS.

Waiting on a fix for this issue. I have 2 ring bells, front and back door. I’ve reset bell and rebooted wifi and restarted the app on my phone. Front door works perfectly fine but back door bell still stuck activating live view. Yesterday when I was reviewing footage, I noticed someone was at my back door. My ring also didn’t make a sound or provide any alert and didn’t catch the person’s face, only their back as they walked away.

1 Like

Same issue here. Spent 3-4 hours waiting and with level 1-3 support. Reinstalled app, reset ring multiple times, reset WiFi and modem. Finally they sent a replacement and same issue. No love view. Have another ring on same WiFi and no problem. Very frustrated as over 4 hours w support wasted

For those having issues, do you guys also have Comcast/Xfinity as your ISP? I’m also having the same issue with Live View.

1 Like

I am having the same issue. We have xfinity :slightly_frowning_face:

After many hours of trying different settings I’ve found that if I disable the Customerisable Motion Detection Live View works ok, either opening from the app or via a notification. If you use the customised detection it’s mainly miss with an odd hit from time to time. Seems to be dependant on how much of the field of view you are pointing at (although don’t quote me on that).

1 Like

I tried what you said and after the next motion activation, the live-view problem was fixed. Appears there is indeed a bug with the app that the ring team needs to address. I hope they are reading this message and they will fix the bug for all of us!!!

Hello I’ve been having this same issue for a while but when i tried connecting my Ring doorbell my phone’s hotspot to test it live view worked pretty fine.
I think the problem is from my router’s firewall settings.
Anyway this out …

And i hope it helps you all.

This has been an on again/off again issue with the main Ring app for a long time. I’m again having the issue myself, but the Rapid Ring app is able to connect to the live feeds with no problems whatsoever. Ring has one app that works, and one that is broken. It is not our connections etc. Stop giving us pass-the-buck excuses. Your app has a problem.

1 Like

GsQs is Spot on! I have the same problem - Live View works on Rapid Ring App but not on the regular App. What a shame!

how did you reset bell, reboot wifi and restart phone app? Thank you.