Live View not Working with Dual Sim

Hi
So I have my iPhone 11 Pro that has iOS 15.3.1, here in Australia I have two providers Telstra(Physical) and Vodafone (E-Sim) when I turn the second line off the live view starts working, it doesn’t matter which line I disable it starts working.

I have uninstalled the app and re-installed the app, reset the network settings, even restarted the phone

on LTE Im getting great speeds over 100mbps.

My Ring Door Bell has Great Wifi (-48 RSSI) and there’s no issues with download or upload speed

Doorbell is hardwired with a ring transformer

Rapid Ring works ok but occasionally drop outs.

2 Likes

This is a unique setup, in which there may be configurations with these plans or cellular network details that might be best explored with your cellular provider support. That being said, please ensure there is not a VPN enabled and that both plans do allow for streaming quality videos over cellular data.

With the Rapid Ring somewhat working, this could be a sign of processing abilities with the mobile device and dual sim networks, in which it would make sense for the smaller Rapid Ring app to work better.

Just to be sure, feel free to check in with our support team for a more in-depth look at this. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

Same issue here; when only 1 sim active, no problem, either which sim. When both active, no live view

1 Like

They are not alone with this issue and it has nothing to do with the provider, as if you disable either provider and am only functioning off 1, it works fine…

Please fix this issue.

2 Likes

I just wanted to chime in and say I’m having this exact same problem. It took me a while to figure why I couldn’t live stream my cameras, but I finally figured it out and can reliably reproduce the problem. What is also interesting is that, when I have the problem, and can’t stream inside the main Ring app, I CAN stream in the RapidRing app…

1 Like

Same here. Works fine on Wi-Fi but as soon as you use cellular; it take a long time to load if at all.

I’m glad I’m not the only one here but I wish they would fix it. The only work around is to turn off the data you aren’t using which is a pain.

If anyone else has a solution please say hey :slight_smile:

1 Like

Exactly the same issue for me. It took me almost 2 years to understand in which conditions it happens, I already called support a lot of times but they weren’t able to help me.

No issue in one of following conditions :

  • on wifi
  • with rapid ring app (but will no more be available), even with both cellular simultaneously enabled
  • with ring app after disabling the second or first line (work on both if only one is active at a time)

Issues (no live view, streaming not working) in following conditions :

  • With ring app when both cellular lines are enabled

No issues on provider side, issue is on ring app

I’ve already tried changing cellular preference when both lines are simultaneously active but nothing changed (cellular line data preference, data auto-switch on /off between lines,…), only way is to completely disable one of the lines which is not a solution…

Thanks in advance to investigate on Ring App,

Christophe.

I have the same issue. Ring support is blaming my mobile phone provider (bandwidth, possible sim problem). With 2 sim cards in an iPhone Xs (e-sim and a physical sim) live streaming is not possible. Disabling one of the 2 sim-cards solves the problem. There was no issue with RapidRing app.

Suffering with the same problem, dual sim and can’t get live view.

Same issue here with dual sim which I’ve since I installed the Ring doorbell, my wife and I both have an iPhone 11 however I have dual SIM on mine with Vodafone as the primary and EE as the virtual SIM. If I deactivate either provider and just have one provider live view works just fine so it’s not the mobile operator as both work when they are the sole network on the phone but as soon as dual SIM is activated live view fails to work. I’ve tried various troubleshooting ensuring no VPN settings are in-place, deactivated data switching etc. but nothing solves the problem so keen to see if anyone else has managed to find a resolution.

1 Like

Same issue here with dual SIM and Live View. Full cellular data coverage (4 bars) with both data providers (AT&T for physical SIM, Verizon for eSim). Occurs with and without VPN activated on phone. Using iOS device with latest OS app and lates Ring camera FW.

When I disable either of the 2 (unlimited data plan) cellular data plans, Ring Live View works perfectly. However, with both cellular data plans active, Ring Live View gives a streaming error for Live View. Yet, 30-60 seconds after initiating the Live View and getting the streaming error, I can view the recorded video from the Live View event in my timeline. Note I did not have this issue with the (not discontinued) Rapid Ring app and my dual SIM phone, as this was functioning correctly in Rapid Ring for at least 2 1/2 years. Problem is reliably reproduceable at different locations with various levels cellular coverage for both data plans.

Ring’s answer of this being a “unique setup” is BS. It’s not a cellular provider issue, or it would occur with one of the cell providers when individually activated. Ring needs to esclate this to technical support and resolve the issue with their app. At least 11 users (including myself) report the exact same repeatable issue. C’mon Ring!

1 Like

I have diverted my 1st sim to 2nd number and turned off the 1st sim, now I am getting the live view until I get another solution.

Hi there,
I wanted to report this bug as well from France. Using both eSIM (Orange Carrier) and SIM ( SFR carrier) on an iPhone 11, live view is not working.
Switching one or the other off will restore the live view.
No issue with Rapid Ring.
Dual SiM mode on a Pixel 6 Pro doesn’t cause any issue though.

I have since been on to both general and then advanced technical support who confirmed they are aware that the Ring application is not compatible with dual SIM but at the same time had no plans for an update to the application to fix it. In fact the whole support experience was pretty poor to be honest, if they admitted that dual SIM does not work in such a configuration which is not uncommon then it should contained within the small print and/or a statement somewhere for people to be able to make an informed decision before purchasing a product that does not work as advertised/intended.

Based on my conversation and experience with their technical team I have zero confidence this will be resolved and that my escalation has been taken seriously so the only way in which this will be fixed is to raise its priority for the software development team by as many people raising a grievance otherwise unfortunately you’ll either have to RMA back to Amazon and move to another doorbell or just live with it.

Uk, dual sim user. I also have the Live View issue when both sims are enabled.

If I disable one of the sims - it works as expected.

I have done extensive testing and I have reported the issue to Ring many times - I hope they resolve this issue asap.

Rapid Ring works with dual sim and Ring claim to have integrated the Rapid Ring features into the main Ring app - devs have obviously missed this part.

NL user dual sim on iPhone 12 exactly same symptoms… if I turn off one of the lines works like a charm! Rapid ring is not available anymore on the App Store. So Ring please fox this ASSP.

1 Like

Australian user with dual SIM cards on Telstra. Dual sims were also not working for me, but I fixed it (for me!).
Of course, turning off one sim works but not a particularly useful solution. On an iPhone, “Settings/Mobile/Mobile data” points to one of the SIM cards. Then for the other SIM card (the one NOT being used for mobile data), set “Voice & data” to be 3G (with your Sim being used for the data no doubt set for 4G). Then it works for me! Both sims are happily able to send and receive phone calls and texts, while the cellular data is taken from the nominated one.
In my case, if I set “Voice & data” for both sims to be 4G the main ring app doesn’t work (I also agree that the Rapid Ring app DOES work in this case, but I foolishly deleted it, and can’t reinstall again).
So, give that a try! There doesn’t seem to be any downside with setting the non data sim to be 3G (until your carrier turns off 3G, but that’s a few years off yet, and I would think Ring will have got their act together by then!).

1 Like

I shut my Wi-Fi off and it seems to be working now.

I am running dual esims with Verizon on iPhone 14 pro in United States. No errors.

Created a community ring account to report I am also experiencing the same issue as others have reported.

The only fix is to turn off the esim. Which is not a solution as I need dual sim services simultaneously active.

Whilst connected on wifi, live streaming works without any issues. Wifi speeds are significantly slower than mobile data service.

This is not a unique set up as it’s clear many people are impacted globally. RING PLEASE INVESTIGATE THIS ISSUE.

Dutch user on Iphone SE2020, same issue.
Was on the phone with Ring 6 times in the last 4 days, got to the “Smart guys tier” 3 times. Finally, by accident, discovered the rootcause myself. Contacted Ring again with the information, they bounced me off to Apple and my celservice provider.:-1:t2:

Tassiebean’s workaround works perfectly. Downside, as already mentioned, once they start taking 3G down you don’t have data connection on that SIM anymore.

This happened for us Dutchies in march 2022. For anyone in the same situation, if you have no issue in using one of your Sim’s as a call/text-only connection than this will work.
For all others, your second connection will be slower.

Stil contemplating to return the set and use an alternative brand smart doorbell.