Live view not working on stick up cams 3rd gen though works for doorbell

Sorry to hear about this experience, neighbors! The best first step will be to check the marked solution in this thread, which contains numerous steps to resolve this concern. Most importantly, wifi resources and signal strength will ensure for an efficient video connection.

I recommend also testing live view when the device is plugged in, and battery removed (using plug in power only). If this concern persists after trying all the steps we’ve recommended in this thread, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

Ok, so I did not give any follow up to this problem on my side but I made some advances.


Here is how the problem was tested and bypassed on my side.

I have numerous types of Ring devices : Ring bells (both working perfectly), wired POE Ring camera (working perfectly), Ring stick cam x 3, battery powered, solar powered and plugged, none were working properly.

The diagnostics i was able to make is that this is deffintly a connexion issue.

The disconnection problem only happen when using my wifi mesh system (TP LINK DECO) on both houses were it is set up.

When I switch to an old router 2.4ghz only wifi, the issue is not happening.

When i connect to a Ring wifi extender, the issue is not happening.

Please Ring it is time to give this issue a real concern and try to debbug it. There is deffintly a patern here.

Is it a problem with 5ghz networks ?

Is it a problem with fast roaming on mesh systems ?

Common this cannot be rocket science !


And PLEASE: stop reposting the standard debugging solutions everyone here has tried thousands of times. They are NOT working !

Thanks again for reading and giving this a correct follow up.

Stay safe,



When I was installing my Ring devices one of the things that struck me was this FAQ from Customer Support:

" Do I need a wifi connection to set up my Ring device?
Yes. Ring devices require a wireless internet connection for operation. Ring devices are compatible with wireless routers running 802.11 B, G, or N, on 2.4 GHz."

That’s how I have set up my devices. I haven’t seen anything that shows them working on

5 GHz.

1 Like

Hello fellow Ring stick up cam victims,

I just purchased four Ring outdoor stick up cameras and the solar panel plug-ins. I also purchased three TP-link Wi-Fi extenders which work on dual band with strong signals. Without the WiFi extenders, the cameras would lose their connection and not go into live view while using either regular or rapid app. Now, all but one camera works well, even one with a RSSI of -66 to -70. What is strange is the one problem camera nearest to the router is mounted just outside my patio door, yet it has a RSSI -52 and loses connection and won’t go live view within 1 to 3 hours after being reconnected manually. My plan tomorrow is this: I will remove the device, reset, and reinstall, but if this does not fix the problem permanently then I will return this particular camera and get a new one and give Ring one last shot. Hopefully ring customer service can submit these reports to their appropriate department. This thread has been going on for months. Thank you everyone who has submitted comments regarding your problems. People like myself benefit from reading issues that have been reported by other people and helped me realize we’re not alone in our customer complaints. We are in this together!


Since my setup with my 4 Ring cameras has been working well for over a month and seeing that some posters are still having problems, I want to share my setup in the hope that it might help some.

I first started hooking up my 2 floodlight cams a year ago. One was working fine from the beginning, RSSI around 38. The second one had an RSSI of 76 and was erratic, up and down. Bought a cheap 2.4 GHz extender and the RSSI went to 23, no problems since then. A few months later bought a Spotlight cam. On install the RSSI was 67 and at times could not get a Live View and other times connection failure. Got another cheap extender, this time dual band, 2.4 GHz for cam, 5 GHz for Echo Dot. RSSI is now 44, no failures.

About 4 months ago bought a Stick Up cam. My troubles started almost immediately. I had hooked it up to a Linksys extender 2.4 GHz. RSSI was 35 so I knew that wasn’t an issue. At times the cam was unresponsive, lost communication, and also the view on the dashboard was totally washed out. While calling support and not getting results I went through 3 firmware upgrades. All of a sudden, one day, the cam started working as it should and it’s been like working fine for over a month. I believe that it was a firmware update that corrected whatever issues the cam had.

Mine is doing the same thing… it’s closest to the connection internet router yet it doesn’t ever work … the doorbell and back camera is fine and has never not let me live view … how do you fix it cause I’m ready to return all 4 cameras

1 Like

How is this marked as resolved? It’s clearly not, there’s so many people complaining of the exact same problem.

Signal strength, fine.
Videos uploaded due to motion detection, fine.

Activiting manually, fine.

Live view - not fine!

I’ve narrowed it down, for me - live view works if i do it straight after the device auto “health checks” (which i’ve waited for by sniffing network traffic). About 5 minutes after that, liveview no longer works until the next health check


I seem to be having the same problem with my spotlight cam, I noticed this seems to happen a lot when the motion is detected and I get the notification, I go to look at live view and it seems to be stuck on activating device and trying to process the recording rather than go to live view. This is intermittent roughy 50% of the time.

I also find the motion zones settings for this cam really poor and not very adaptable. There should be a lot more scope for adjustment and variation. The app adjustment for this is also poor as you can’t see as you are adjusting the size?

1 Like

Definitely not solved!!!

1 Like

I have a ring Stick Up Cam Battery with Solar Panel and I have the same problem. What I noticed is that the issue happens most of the time during the day when the power is being supplied by the solar panel (power source shows it is not using the battery which is also 100% charged). When it gets dark and power switches to battery only, there are no issues. So it looks like during the day, even when the RSSI is between -40 to -55, the solar panel cannot supply enough power to the camera. In the Ring site, it says that “When plugged into an outlet, Stick Up Cam Battery will be powered by the adapter and will use the battery as backup“. Although I am not using an adapter, it recognizes the power from the solar panel coming an adapter. Can somebody confirm if they are having the same issue and what is the possible solution? Is there a firmware update that can fix this issue?

1 Like

For my Stickup cam I have exactly the same setup: battery and solar panel. If you read my previous postings, my last issue has been on April 24th, since the it’s been working perfectly. What I see in your post is that your RSSI swings from -40 to -55, that’s quite a spread. You could have interferance in your channel. My RSSI holds steady at -33 to -34. day and night. In my neighborhood I have a lot of 2.4 and 5.0 GHz users so I look and see what channels are available on 2.4 GHz with the least or no usage and that’s what i select. Ring has published a chart for the cams and I set up my routers and accordingly. Everything works fine.

In that chart see Compatible Networks, make sure you’re at 2.4 GHz. Some have tried to set up their cams at 5 GHz. I did too in the beginning, did not work too well.

Sorry, haven’t read all 10 pages, but have people called Ring support? They are able to escalate to advanced technical team, who can in turn escalate to engineering.

I have the same issue and Ring support have sent a replacement, which I don’t think will make a difference based on others having the issue.

There are numerous thread this weeks with the issue so I think caling and escalting is the best option.

1 Like

Got the same issue here. Really wish I’d spotted this thread before wasting a couple of hours on the phone to tech support. Just received two brand spanking new cameras as direct replacements for my old stick up cams which I rasied the issue with. That’s the good news.

Bad news: there’s someting defintely off with the cameras themselves:

  • Doorbell works perfectly, always has done

  • Initally the cameras worked perfectly, then noticed they would regularly not alert or show live view

  • Tried new batteries, rebooting units, removing from ring and re-adding no joy

  • Reset wifi router several times, tried 2.4 only, 5ghz only no joy

  • Replaced router with expensive wireless mesh system no joy

  • Replaced stick up cams no joy

  • Changed out DNS settings to go to google’s DNS servers, all ports opened, checked ISP not blocking the ports Ring told me to check etc. All no joy

Thinking back, this all seems to have started when they deployed the extra motion functionality and home/away modes. The stick up cams have been unstable ever since.

Logically it can’t be my network config or ISP config or the cameras wouldn’t work initially on reboot. Can’t be wifi as that’s all new.

Think the cameras are just pants and we’ll have to wait for a firmware update to correct. I’m not impressed in the slightest.

NB: As I type this, the kitchen cam has suddenly started working again, with no changes or intervention from me. Backs up the fact that the network, wifi or internet is not configured correctly. Unstable rubbish.

1 Like

I had a very similar issue. I have a doorbell pro, floodlight cams, and a spotlight cam that all work perfectly. I had issues with the 3rd gen stick up cam immediately. I initially set it up in the same room as my router just to get it joined to my network and test it out. I had to go through the initial setup twice to get it to connect. Then the live view would only work sometimes. Against my better judgement, I mounted it outside. It worked for like two days, then it wasn’t recording motion and I couldn’t view the live stream. Power cycling did nothing. I had to climb up on the ladder to hit the setup button and re join it to my network. It worked for a few more hours, and then stopped working again. That was the last straw. I took it down and returned it. I replaced it with a refurbished 2nd gen stick up cam that has been working like a champ. Something is defective with these 3rd gen cams.

1 Like

I spoke to support yesterday for 40 minutes and have sent 8 community links where people have posted about the issue (inc this thread). I’m not hopeful this will get resolved any time soon :frowning:

1 Like

Has anyone had any kind of positive response since all of these threads have been running? I’m still at square one even since Ring very swiftly replaced my two stick up cams (and due to C19 the old cams haven’t been picked up yet).

I might raise another issue with support if I get a couple of hours free.

1 Like

After a 40 minute call, support were still suspecting my network was the issue. Despite me mentioning the other devices never had this problem and that numerous other people have the same issue with stickup cam gen 3.

I’ve again sent them numerous links from the community.

1 Like

I have not called tech support because of all these threads posted over many months with no definite solution. I have 4 gen3 cams mounted outside. One of them seems to stop working just as many have described. I want a refund or replacement. Three of the 4 cameras work well and have dedicated wifi extenders. That may be a possible answer but nevertheless it shouldn’t be! Anyways, thank you all for posting your experiences!

1 Like

This is now 100% solved for me now. Here was my solution: took them back to John Lewis for a full refund.

JL were fantastic, no box or receipt but full refund without any argument as soon as they checked online and saw the support forums with many threads all with the same unresolved issue.

1 Like