Live view not working on stick up cams 3rd gen though works for doorbell

Wow. A lot of people with problems with the Stick Up Cam. I felt the need to throw my hat in the ring.

I had my Ring Alarm system and stick up cam for almost a year. For the most part no problems.

However, this changed around the time that they came out with the Motion Verification Feature, which I initially enabled. I thought that was causing the problem below, so I turned the feature off. That did not solve anything.

I am often not getting notifications for movement. When I look at the recent events, the video picture is overexposed (very, very light) and the picture pauses a second or so once a person or object enters the frame. The video will remain stuck for about 30 seconds to one minute. The end of the clip is normal, but it is generally after the person or object is out of view.

Moreover, I am not able to access live view. All of these are problems when using the App on my phone or the website on my computer.

After reviewing video clips, it looks like this has been going on since around April 2nd or 3rd. Some of the videos clips are completely black.


As a follow up to my previous post, one of the things that seems to have been fixed, is that the Stick Up cam dashboard picture is no longer overexposed to the point of being totally washed out. All the cams are updating the view at the same time when I access the Dashbord. Going to keep an eye out to see how long it takes for the stick up cam to become unresponsive. PS The Floodlights and Spolight update the Dashboard view every 60 seconds and the Stick Up every 10 minutes.


I am having the exact same issue.

One 3rd gen cam works perfectly, whilst the other two are useless…tried removing, resetting, using a different network and the same issue. Won’t show live view or update when the app is refreshed.

I am not spending hours going through everything I have already done and somebody at Ring needs to sort this out sharpish!

What a total waste of money!!!


I understand your frustration. I just checked my cams and the stick up cam is still working fine after 16 days. What I remember is on initial install, it did a firmware update. Then on one of my troubleshooting it did another update. Finally on my next to the last problem there was a third update. Ever since then, so far, it has been working ok. What I also noticed is that before the firmware had a number now is “Up to date” like all my other cams.

1 Like

Make sure “cellular data” is turned on for the Ring App. I was having the same issue. I recalled that during a previous troubleshooting episode, I was instructed to turn it off. After turning it back on, all is good. Hope this helps.

1 Like

OP here again. I’m not really sure what happened but live view seems to work for me quickly on the doorbell and cameras. Like a couple of others have said, the doorbells finally say “up to date” when I check the firmware rather than a version number. Other than that I haven’t noticed anything and I hadn’t actually done anything to fix it lately. Maybe the key was staying home for many many many weeks. I’ve not tried it anywhere but home as I have not been anywhere but home since March 11th. I’ll give it a try remotely some day when I can get out of here.


I too am having the same issues outlined by others. I’ve gone through the troubleshooting steps that others have gone through as well. It still doesn’t work. As a product manager myself, I firmly believe this is a firmware issue. (pun intended). I’m happy to work with Ring to troubleshoot but I’d ask their product team reach out to me to help resolve. Happy to help where possible.


Exactly the same problem here. I’m in the UK with various ring devices. Ring Video Doorbell 3 plus works absolutely fine with Live View and shows the last health check as only one minute ago. However my two 3rd Gen Stick Up Cams will not show live view, both just state “streaming error”. Device health shows that one of the had a health check last completed 5 hours ago and the other had a health check last completed 23 hours ago! Terrible that Ring haven’t fixed this issue despite the amount of complaints on this thread!


I pulled the battery out of mine. Waited a couple of minutes and put it back in. Then reinstalled the cam via the phone app. Working proerly again. Fingers crossed…


…unlike my typing. Working “properly”.

1 Like

I have done this with mine. Work for a day or so and then they fail again.

I have to now check the app and see surprise when all cams show they are working. They seem to work when and how they want to!

This has to be a firmware issue??


Why is this thread marked as solved when it clearly isn’t???


I just installed a plug in stick up cam. It is always preventing live stream viewing stat that the battery level is critically low. I bought this so I wouldn’t have to worry about the battery. I selected the plug in option during setup. Did I make a mistake somewhere?


there is a big thread about this topic.


This will be my final update on this subject. It’s been 30 days of monitoring my Ring cams and I’m happy with how they are working. In betwen we had a 6 hour power outage in the neighborhood. Once power was restored and my routers and extenders came back up, all my cams came back online by themselves. This included my previously problematic stick up cam. On my part I would have to say that whatever the Ring team did, it worked.

1 Like

Same here, also in the UK. Still not fixed. I’ve had 2 of these cameras for a few days now and they simply don’t work. My doorbell 2 works fine. Done all the usual to the stickup cams, it’s clearly a firmware issue or maybe a server thing on ring’s end. Shocked at how long this has been going on, makes me think they aren’t going to fix it any time soon :frowning:


Indeed, I have just invested in the 10 piece alarm system and it’s great (so far!!!) alongside my ring doorbell 3 which has been flawless despite it being at our gate and quite away from the house, and then the stick up cam is just seriously flawed in comparison, even now when popping the battery and replacing it, I can’t get live view!!! I thought it was because I keep moving it around the house as that it what I bought it for (to keep an eye on my puppy) but even now having left it in one place I still have the issues.


Sorry to hear about this experience, neighbors! The best first step will be to check the marked solution in this thread, which contains numerous steps to resolve this concern. Most importantly, wifi resources and signal strength will ensure for an efficient video connection.

I recommend also testing live view when the device is plugged in, and battery removed (using plug in power only). If this concern persists after trying all the steps we’ve recommended in this thread, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

Ok, so I did not give any follow up to this problem on my side but I made some advances.


Here is how the problem was tested and bypassed on my side.

I have numerous types of Ring devices : Ring bells (both working perfectly), wired POE Ring camera (working perfectly), Ring stick cam x 3, battery powered, solar powered and plugged, none were working properly.

The diagnostics i was able to make is that this is deffintly a connexion issue.

The disconnection problem only happen when using my wifi mesh system (TP LINK DECO) on both houses were it is set up.

When I switch to an old router 2.4ghz only wifi, the issue is not happening.

When i connect to a Ring wifi extender, the issue is not happening.

Please Ring it is time to give this issue a real concern and try to debbug it. There is deffintly a patern here.

Is it a problem with 5ghz networks ?

Is it a problem with fast roaming on mesh systems ?

Common this cannot be rocket science !


And PLEASE: stop reposting the standard debugging solutions everyone here has tried thousands of times. They are NOT working !

Thanks again for reading and giving this a correct follow up.

Stay safe,