Live view not working on doorbell Pro

I have Ring Doorbell Pro wired to Ring transformer.

Since 3/18, I am unable to open Live View on my phone.

When I click on the Live View, the Activating Device spins for several seconds and then I get a “Failed to connect. We’re having trouble connecting to your Front Door” message.

If I go back to the app, the Preview shows the correct picture as of now. So, the picture is updated in preview, but Live View does not work.

The RSSI is -45, the download and upload speeds are 38 and 10 Mbps as tested in Ring app with my phone next to the doorbell. Everything is green. No issues are shown.

I have cut power to the doorbell and then powered it back on, rebooted the WiFi router, but nothing seems to help.

Every time I check the Live View, the event is recorded in history, but I cannot play it back. The doorbell is detecting motion and showing it in the history, but when I try to play it back, nothing happens.

Is the doorbell camera dead? Then how it is able to show the correct picture in preview window?

The same problem happened in December of 2020 and I had to factory reset the doorbell and re-add it. Then it worked fine for three months and then same problem.

Any ideas what I can try?
Thanks,
Arun

I have fixed the problem!! The latest app update has broken live view, but you can uninstall the latest update and install an older version of the app by going here and download the Android install file for the older version (3.35.1):

It is not a problem with the app. I use the same app on same phone to view another Ring camera at a different location and it works fine. It is just my doorbell which is having the issue.

Hi there, @AGupta! The Video Doorbell Pro is capable of connecting to 2.4 ghz and 5 ghz networks, in which 2.4 ghz can be more dependable over distances and through exterior walls. With the Ring app working as intended for another Camera, this does indeed rule out many factors. Try out the Rapid Ring app, which is less robust and designed for the quickest access to live view.

When you mentioned;

feel free to check your subscription status by logging in at Ring.com via web browser. Please let us know how this goes. :slight_smile:

Is it a problem with the app and many many phones. So yes, it’s a problem with the app, although I suspect Ring only tested it on a limited number of apps. Look bro. As soon as I installed an older version of the app, Live View is now working flawlessly.

Issue is resolved. Someone at Ring decided to change port to TCP 8557. As soon as I opened this port, live view started to work. If they keep changing things at back end, it will be hard to keep up.

Can you please find out why they added TCP port 8557 instead of using the ports documented in Ring documentation?

The most common causes of not being able to do a Live View or see a recorded video are: A poor connection between your mobile device and the internet. Slow internet upload and download speeds. A poor connection between your Ring device and your router.

garageband

Hi there, @AGupta! Our help center article about ports and protocols provides further information on ports used by Ring devices. In the article linked above, you will see both well known and specific ports listed, as well as additional recommendations. In most cases, your network configuration should not block ports used by Ring devices. As you mentioned opening a port, double checking with your internet service provider is always a great step to ensure nothing is being blocked.

As we always value our neighbors’ feedback, consider this experience shared with our teams here! :slight_smile:

Wrong, it’s a bad app update. Downgrading the app works fine.

I have the same issue, works fine on Alexa show and I can open live view if I turn on mobile data, it just won’t open live view via my home wifi. Only been installed a week, I consider this free trial for thirty days a trouble shooting period and have so far encountered IR issues, resolved with the use of tripping the signal with a torch and now the live view. I followed all the instructions and advice, checked my speeds, rebooted wifi, went through pro set up again and downloaded the rapid ring app, none of these things worked. I don’t mind using mobile data or Alexa show to open live view if needed, I just wish I didn’t have to as the app should be operating as promised.
I’m all ears for solutions if anyone has any. Thanks ( I’m not keen on installing older version of app, not that I doubt it works, I’d just prefer a reliable function)

Edited: had to come back and update, it’s been six hours since I posted this and during that time I had just reverted to using the alexa app for live view, as soon as I turned on notifications for doorbell there, the IR issue in the camera returned and now cant get it back with the use of shining a torch onto it. Not really feeling it anymore and will probably return product and request refund before thirty day period is over.

How do you change port?