Live view not working. Everything else does

Nothings changed but live view will not connect. Have had everything up and working for at least 7 months with no issues. But for the last month or so live view has just stopped working.
Have good connectivity, 4 cameras, including 1 doorbell. All are battery powered. Fully charged.
NOTHING has changed. Live view now just spins and says “connecting”. Will record what I’ve “watched” but doesn’t show the live picture. Great for a security camera…

Any help?

5 Likes

I am having the same problem. It started about a month ago. Any help out there. Can’t find any words of wisdom on line.

Mine won’t connect to live view while on cellular connection. If I switch my phone to WiFi it works but it’s useless if I’m away from home and not on WiFi. It started about a month ago too. My suspicion is that the latest update has a bug in it.

1 Like

Have you upgraded your phone?

I believe this is to do with IOS update. My wife’s phone is 14.7 and works fine mine is 14.8.1 and no live view.

This is happening on our system too. I can view live view on my iPhone but my wife cannot on hers. Both phones are IOS 15.1.

Try out the Rapid Ring app, designed for the quickest access to live view. Please also ensure there are no VPNs enabled on the mobile device. As other neighbors suggested prior, testing wifi versus cellular data connection is another great step. I hope this helps! :slight_smile:

4 Likes

I’m experiencing the same issue with my Ring Doorbell 2. It’s really frustrating because it hardly ever works but used to decently well. I’m thinking about replacing it with an Arlo Doorbell if not able to get this rectified because I have several arlo cameras connected around my home that work consistently well (and a couple of them are twice as far from my router). Things I’ve tried…

  • Reset my router
  • Reset my Ring
  • Changed the Wi-Fi network. This actually solved the problem but only temporarily. After doing this, I could access live view but after only once, it no longer works. I tried again, and same thing. THe first time after changing the network it worked, but hasn’t worked since.
  • I have a Samsung S20. I’ve tried repeatedly connecting using my Wi-Fi and non Wi-Fi (cell). Neither will work.
  • I checked the device health and everything looks good, including a Signal Strength of RSSI - 53.

I don’t know what else to try. The strength of my wifi to my door is solid. Everything else works fine. It records video when it senses motion and I can view the recorded video. The problem is only with the live view.

1 Like

I have this exact same issue with my floodlight cam, and like others it started about a month ago.

Try accessing your camera from the web at ring.com. In my case, the floodlight cam works PERFECTLY on ring.com - Live View, recorded videos, you name it. The hardware is fine, the connection to the wifi is fine, and nothing changed from over the summer when everything worked fine.

Since October on my phone, I can’t access Live View on the one camera where I need it the most. It’s a Pixel 6 Pro on the latest version of Android, not some antique phone running Android 4. Despite the reboots, remove/add device, add to Pro Network, check RSSI, etc., it’s 1,000% a compatibility issue with the phone app that Ring needs to pay attention to and address ASAP. @Marley_Ring

1 Like

I have tried using the Rapid Ring App, no difference. Still does not work. I’ve tried accessing via my pc by going to ring.com, does not work either. I even took a range extender to boost the wifi (even though the signal is strong) and that doesn’t work. I’ve tried everything that
has been posted to try as well as everything that is listed in their support section online.

I’m about a day removed from selling this on ebay and getting a different brand because this is ridiculous. It seems to me this would be an issue that Ring would jump all over to correct. I have a video doorbell that won’t show me video when I want it. Perfect. Makes sense for a SECURITY camera.

3 Likes

And did you check the Ring Status page to see they are having issues at the moment?
Ring.com Status

1 Like

This isn’t about today, this has been going on for weeks.

1 Like

It would explain why you are having issues today might it?

Don’t forget to use Ring Support ( Contact Us – Ring Help) to help with your issue. Be aware wait times can be long and it may take a couple call backs to get someone who’s able to assist you.

1 Like

I also am having this issue.
Each time someone rings the doorbell, you see the instant alert and tap on the alerts and the app cannot load and hangs there.
The issue is not my phone, not my WIFI, not my doorbells.
I have an s21 ultra, rebooted devices, cleared DNS on WIFI, running up to 1tb in WIFI mesh which extends well over onto the next block of streets. I am using the latest doorbell pro’s and I have uninstalled and reinstalled the app and same issue.

I have tried this on other devices and having the same issue with the live alerts.
I then tested the Rapid Ring app and it is a 50/50 shot of it working.

Any suggestions?

3 Likes

It’s almost certainly a well-reported issue with the Ring app on your phone. Until they update the app to make it functional again:

  • Check your Live View on ring.com. If the camera and Live View works fine there (as mine does), you’ll know it’s not a hardware or connection issue
  • Uninstall the Ring app from your phone, and download/install an older functional version. Version 3.35.1 worked for me and others. If this version of the app works for you, you’ll have even more certainty that it’s an issue with the most recent app versions (as many other have reported).
  • Disable “Auto Updates” for your apps on your phone, to avoid having your system install the non-functional recent version of the Ring app
  • Keep monitoring this board to find out when they actually fix this problem
1 Like

Try turning off WIFI on your phone and using the cellular data to connect instead. I’ve been having this exact problem. Everything works and the camera picture is crystal clear until I try the live view. When i try launching the live feed, the picture is grayed out so you can’t see anything. After reading the response from Marley_Ring, I turned WIFI off on my phone and tried again. The Live feed came up immediately with a clear picture. It must be the cellular data connection causing the issue when away from home.

Glad that turning wifi off worked for you. However, for many others, that doesn’t do anything. I’ve tried everything suggested on this forum to rectify the problem, except of using an older version of the Ring app which was just recommended. I intend to give this a try. I’ll report back to let people know if this works (for me).

I appreciate the suggestion, and I’ll give that a try. However, why would it be an app problem if live view also fails to work when logging in from my pc?

What I meant was that it’s an app problem if everything DOES work fine from the PC. If you have a an app, website, whatever that has no problem serving up the content, then you an rule out a) a hardware issue, and b) a connection issue between the hardware and your home’s internet connection.

It’s important to rule those things out; Ring’s Tier1 support will have you disconnect hardware/reconnect it/reboot routers/make you connect to a Ring Pro network instead… everything under the sun.

If it works on the web browser, but not on the mobile phone app, then the issue is the mobile phone app. If the web browser Ring app ISN’T working, then the problem could be anything (hardware, internet connection, etc).

1 Like

Okay, I downloaded the older version of the Ring app (3.35.1) and still does not work. I have now tried every suggestion provided to me. This Ring doorbell sucks and is going in the trash (literally). I ordered an Arlo doorbell and will go in that direction. Why should I work harder than the customer support folks? Funny thing is, if you read these boards, this is happening to many other people as well. Too bad, I really liked the Ring doorbell when it worked. However, no doorbell is worth this much aggravation.

2 Likes