Live View not connecting, will not activate

Live View not connecting, will not activate

Hey @Rocket61! Live view concerns are often related to connection or wifi signal strength, which can be checked by the RSSI in your Doorbell’s “Device Health” in the app. Check out our Community post about RSSI to ensure your signal is optimal for quick connection.

Also, please try to uninstall and reinstall your app to be sure it is up to date and properly integrated with your mobile device. I hope this helps! :slight_smile:

This is useless advice. I use Orbi wirelerss access points with excellent signal strength. - device health reports RSSI-60. The app is properly installed. It takes forever to activate the device if you want a live view - if it happens at all. It responds quite well to motion or someone ringing the dooorbell. It loses a lot of its usefullness if I can’t see what is going on right now. I will probably throw it away and get something else.


My ring was activated in February and has not worked since June. No live view, no pic, just colored lines. I am so frustrated with this device!


Hey @orletsky! An RSSI of -60 is an indicator of distance or interference enacting upon your wifi signal. Check out our guide to a good RSSI here, to see what is considered optimal RSSI and how you can improve your signal strength for the best experience. I hope this helps!

-60 is a bit high for RSSI. Do you have it connected to a Chime Pro? Also, it’s important to check on the connection on your smart phone. For example, I don’t have the best service at my grandparents, so live view takes a little longer than it normally does at my place. Have you talked to support for proper diagnosis?

I’m having the same issue!!!


I have the same problem.they sent me a replacement and it worked for about a week or two and now it’s doing the same thing. I have a $26 wyze camera that works great and I’ve never had a problem with it so from now on I will be buying all wyze products. This is good for recording and ringing the doorbell but if someone was breaking in my house and I’ll try to activate it I guess I’d be long gone and sold everything and be home by the time I ever got a live again. it’s a high price piece of junk that they have been having problems with for a while at the live activation. Meanwhile they try to say is on the user’s end when they know good and well that’s on their end. I will never buy another ring product

1 Like

Same issue for me. Just purchased the Ring Doorbell 2 on the firt day of issue and aside from 1-2 days of it working it continually fails to activate on live view. RSSI is -46 and it is literally situated less than 20 feet from my wifi router. Very disappointed in this product. I have multiple ring products and this one I have to say is useless

Hey neighbors! If you’re having a hard time activating your Live View, please check out our Community post here. If you’re still having issues after trying the tips and tricks here, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I have two ring products, my Floodlight Ring and my Ring doorbell. Both are the same distance from my router (the Ring Chime network didn’t help me). My floodlight connects with Live view within 3 seconds, my Ring Doorbell, IF it connects at all, can take up to 30 seconds. The Ring Doorbell PRODUCT itself is at fault. Don’t you think??


I have the same issue. The device will not start live screen. While doorbel function works fine.

RSSI value = 52 and also my AP (UniFi) reports 100% strength.

It’s connecting over 2.4ghz and no issues.

How can this be fixed? My wife is getting very upset about this tbh.

Sorry to hear about this @Mduijm! If certain videos connect as intended but live view does not, try removing and reinstalling the Ring app on your mobile device. This is a quick way to ensure it is up to date and optimally integrated with your mobile device. On your mobile device, try testing video on wifi only, and then on data only, to see if either connection is more efficient. Please also ensure bluetooth and VPN is disabled.

Video connection concerns are often related to wifi, mobile device, or Ring app communication variables. The best next thing to check is your wifi signal strength, or RSSI. Check out our Community post about RSSI for tips on optimizing this signal strength. I hope this helps! :slight_smile:


I already posted my value, which is good right?
But have not removed added the app again on my phone. We are in iOS and it’s auto updated. However will try it.

Will come back soon.


we have 2 phones, both i removed and installed the app again, was working for a while, but a couple of hours later, again spinning wheel of connecting…

RSSI is -52.

Download speed of my phone at the same spot of the doorbell is 150Mbps(down) / 40Mbps(up)

I use Unifi WIFI at home with 2 AP’s. I learned that the Ring has some issues with that, so I created a dedicated Ring SSID, called Ring :wink: only the doorbell is using that and I only allowed this SSID on one AP so the doorbell doesn’t have to choose which AP…

Reading through this list of complaints, a lot of people have this issue and no real answer is given…

What is the best way of resolving this? I am about to go to the store and buy a regular doorbell… this is frustating, for a lot of money!

please let me know what steps I should take next.

Same issue! Dam things worked fine for first 2 months then the app updates and bam! No live video. Seriously this is ordinary. Nothing changed except something ring installed or updated. I’ve tried just about everything I can think of. . I am using Motorola 7131s, but I’ve also tried Cisco APs to boring old $50 net gear AP.s… All the same. I thought initially it may be a multicasting issue but I’ve tested just about every scenario with igmp settings…including flat out disabled. My Wing 5 logs are stating that the devices are failing on the handshake during group key assignment. This is using ccmp no TKIP. Although I haven’t tried any TKIP settings I highly doubt they will work. I’m going to try to increase the time out on the handshake and see if that helps… Not holding my breathe.
Rather disappointing.

Thank you for being so resourceful, neighbors! Checking on network settings and configuring access points to better dedicate resources to your video streaming devices is a great step. Optimizing network variables is always a good way to ensure for quality video connection. Feel free to also check out our help center article about ports and protocols.

If you live view worked just fine prior, and no network changes have been made, the video connection should not be faltering at all. If possible, I recommend testing another mobile device as well as installing and trying out the Rapid Ring app. The Rapid Ring app is designed to connect the quickest to video. Sometimes a new setup of your Ring device in the Ring app can help to re-establish connection and video communication.

If the above steps do not help to resolve your live view concerns, Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Honestly, the replies from Ring here are pathetic. It’s always “it’s the phone” or “it’s the signal strength” or “reinstall the app”. ridiculous. My doorbell isn’t more than about 6 feet from my wifi router/AP. My RSSI is a -43, and half the time my live view won’t connect.

If ring is not going to put ANY effort into trying to duplicate and diagnose this problem with some proper tools, I wish “Marley_Ring” would just say so, so I can throw these pieces of garbage up on eBay and buy something else.

Seriously Ring, your product sucks, you need to FIX it, not just keep telling people to reinstall the app on their phone.

1 Like

Same issue here, I have a RSS-46, had connected, disconected, upload, unload, etc, etc…whatever Ring tell me to do, still have not connection for the past 3 weeks. I cannot believe the customer service is so horrible for this product. I was expecting better service from a company that belong to AMAZON. Very disapointed. I really don’t know what else to do than swith to another company, because I need the camara working and I cannot keep going around with more nonsense answers.

1 Like

I have the same problem which just started. Switched ISP’s to Verizon, wifi router shows signal strength of -70 SNR 21 rate 70Mbps rate (No very good)which is low. I also have a chime pro which is supposed to boost the wifi signal and I do not think that is working. Chime RSSI i s-38 (Ring app health status) which is very good, but the Verizon wifi router sees the RSSI as -59 SNR 33 rate 28Mbps. I’will add, these problem started once I swapped to the Verizon wifi router. I would have hoped the Chime would boost the signal, but that does not appear t be the case. The signal strength should be stronger as the space is small and separate by few walls. I will swap wi-fi router and reply back.