Live View just stays on "Activating Device" on Mobile Data - (Worked fine previous 12 months)

My 3 Cameras (1 Doorbell & 2 Stick up cams) all hard wired, have been working flawlessly for about a year. The last 3 days whenever I try load the video feed on mobile data (UK EE Network) it just says activating device with no resolve. I can watch historical live views, automatic recordings all fine, just not the current live view (Unless I’m inconveniently on WIFI)

I have re-installed the app, restarted phone, cleared cache, installed Ring Rapid, checked Data saving mode is off, checked all app permissions, restarted devices and router - Nothing has resolved it.

What is most frustrating is that my partner has the EXACT same setup, phone, network provider etc and its currently still working for her.

Huawei P30 Pro - latest OS, Latest App on UK network EE.

This has made the cameras redundant until i can find a solution.

If anyone else come across this problem I manage to rectify it (or at least find a temp work around) -

Thanks to seeing one comment on the 1000’s of forum posts regarding this I tried creating a new mobile access point on my phone. Matching the EE settings like for like, with the exception of IP4/IP6 which I left at IP4. Instantly my live view started working again after days and days of frustration, removing and reinstalling apps and network settings with no change this finally worked.

Still can’t quite work out what’s at fault here weather its EE sending the wrong Mobile Data settings to me or the Ring app not supporting settings that it should.

Adding an Access point on Android (Huawei P30 Pro)
Settings - Mobile Network - Mobile data - Access point names (APNs)
at this point press the 3 dots and create a new profile (as you can not edit existing)
give the new AP a unique name so you dont confuse it with the old one (which you should keep).
Google the AP details for your network provider
EE(UK) was as follows :

Name: EE internet 2 (“2” was to make I unique)
APN: everywhere
Proxy : Not Required
Port : Not Required
Username: eesecure
Password : secure
Server: Not Required
MMSC: http://mms/
MMS proxy:
MMS port: 8080
MCC: 234
MNC: 30
Authentication type: Not Required or just use the default value shown.
Leave IP4 as IP4 and not IP4/IP6
Save and activate
Test Ring live view

Hi @TheSquirrel! Thank you for all this detailed information!