Live View is not working (all devices)

Just purchased and connected the Spotlight Cam PRO

I can see a screenshot, move detection, recordings, … but I can’t seem to view Live on demand. Sirene, lights, all is working well. When there is move detection I can even see Live View for a while but when I re-open the app it’s not working anymore.

Error: (translated from dutch) “There was a problem starting Live View - click on the button to retry connection”
Both on the IOS App and Google Chrome (on dekstop)

The connection to wifi is great (RSSI-57) - same for the Chime Pro
Called tech support: tried resetting it, reconnecting, connecting to WiFi, connecting to Chime Pro, restarting Wifi router, re-installed the app, latest updates, latest firmware - the app show the device as active and online but Live View is not possible

Live View on the Pro 2 doorbell is working just fine
What else can I try…?? Is it just me or shouldn’t this be this hard?
It’s a basic option.
Cheers for any tips

1 Like

Hi @Bennie. You’ve completed all of the troubleshooting steps I would have suggested when you contacted support. Since you’re still unable to activate Live View in the Ring app, I’d recommend following up with our support team. You can do so by calling one of the numbers available here, or you can get in touch with us on social media by sending a private message @Ring on Facebook or a direct message @Ring on Twitter. Our support team can take a deeper dive into what might be causing this.

I’m having the exact same issues. None of my devices will allow live view for the last several day. Everything else works fine. WiFi is strong.

I’m having the same problem with one camera. The other 3 spotlight cams work fine. Also, I bought a new Spotlight Cam Pro and it reacts the same way. The other cameras are Spotlight Wired.

Hi neighbors. If you have tried the steps mentioned in the post and are still having the same concern, the next best step is to contact our support team.

Mine is doing the same thing. Live view is no longer working via the app for people with iPhones updated to 16.4.1. That’s when it happened to me. After suspecting this was the issue, I had my son, who was on 16.4.0, check his live view (it was working), then upgrade to 16.4.1, and it stopped working. I reported this issue to Ring on or about April 18.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.