Live view in app hit n miss

Hi , I’ve bought a battery spotlight camera and when I try and view the camera on the app ( live view ) 9 times out of 10 it doesn’t load , I’ve speed test at the camera and it’s 50mbps , router is literally 10 foot away from the camera , notifications come through on WiFi and 4g but trying to get on live view is ridiculous, I just get the " connecting circle "

Hi @Edgie70. I’d also recommend checking the RSSI in the Device Health screen to make sure the Spotlight Cam is getting a good internet connection. You can read more about RSSI in our Community Post here, which will also have some tips on how to improve the RSSI if it’s high. Additionally, you’ll also want to test out the Live View on both wifi and on mobile data to isolate if the problem is related to one of those, and make sure you have any VPNs disabled as well.

If this concern continues to persist, our support team is available to go more in-depth on troubleshooting this. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:


Hi , I tried with the router on the window ledge and it’s still the same , I call tomorrow

1 Like

@Edgie70 That looks like a Sky Q Hub ER115. Those are well known to have terrible WiFi performance. Also do you have Sky Q TV boxes, the Mini boxes create a mesh network and I have seen devices get “stuck” connected to a further away access point rather than the closest. Try splitting the WiFi bands on the router and connecting the ring camera to the 2.4ghz band.