Live view doesn't work after someone rings. Ring Pro goes offline

Yes, thanks me reminding about that. That work around seems to work but it’s just a bit upsetting that Ring can’t seem to get it right with one app.

I’ve always had this setup with the Rapid Ring app (since it was released) and still have the issue. Once the doorbell goes down by someone ringing it or attempting to speak through it, there is no accessing it via Rapid Ring or the regular Ring app until it has seemingly rebooted, or whatever its doing once it crashes… I assume rebooting.

February 2021 and this is still an issue. Brand new Ring Doorbell 2 purchased in December and mine does the exact same thing.

Doesn’t matter if I use the original app, the ring pro app or the windows 10 app, they all don’t connect to live view when someone presses the doorbell. After they’ve gone minutes later live view will start to work again.

I have a wireless access point in the kitchen (hard wired via an ethernet cable) which faces the window with the doorbell just outside. Signal strength is very good yet I still have this problem.

What a frustrating, essentially pointless product if there’s no way to resolve this.

Hi there, neighbors! If you’ve reached out to support, as suggested above in this thread, feel free to let us know of any solutions you found with our support team.

I’m seeing a few neighbors here narrowing down their video connection concern to button push/ ring events, which is great. Please also test motion events, as well as testing events with your mobile device connected to wifi only, then cellular data only. Please also ensure there is no vpn enabled.

If this concern is persisting, feel free to reach out to our support team, or even respond with further details such as RSSI, mobile device type, or even wifi router type if you’d like. This will help us and other neighbors with providing additional suggestions. Thank you neighbors! :slight_smile:

I have had the same issue for the last 8 or 9 months. My Ring Video Doorbell Pro goes offline after anyone presses the button to ring the doorbell, and I usually have to reset it by disconnecting power to the transformer and then reconnecting it. I had the system wired to an indoor chime, using a 16v transformer (actual output of 21v) and a Power Kit v1, and when it started happening more frequently I read about power issues so I installed a 24v transformer (actual output around 26v) but it still did the same thing. I then bypassed the indoor chime using the recommended resistor and it is STILL doing the same thing. I thought MAYBE it was actually getting too much voltage so I reinstalled the 16v transformer and metered it at 21v at the Doorbell Pro itself. Still having the issue despite trying numerous things. Wifi is strong throughout the house and outdoors (I have a wireless camera much farther away from the door and it works great and has a strong signal, and I am able to connect to my wifi when I am well off my property). Has anyone solved the problem yet?

1 Like

I have the same problem. Sounds like there is a battery in the Ring Video Doorbell Pro wired units that supports the unit for a few seconds while the power is transferred to the mechanical chime during a doorbell ring event. And over time, these batteries die, so when doorbell is pressed and power transferred to mechanical chime, the unit dies. I would have to flip the breaker to get it to reset every time the doorbell was pressed which is ridiculous.

There is a write up on ifixit on how to replace the battery but not for the faint of heart. I wound up disabling the connection to the mechanical chime in the Ring app and put in and linked a Chime Pro instead and it works great again. I suppose other option is to buy a new Ring Video Doorbell Pro but I imagine you will run into the same problem again in a few years when the battery dies again.

Hello everyone. I am having the same problem with the Ring Doorbell Pro at my mom’s house.

I noticed that if we reboot the doorbell via the app, pressing the doorbell, the Live View will work ONE TIME. But pressing the doorbell after that, the Live View will not work.

I thought it might be a weak transformer, so I replaced it with a 24v 40VA but it was no use.

I raised the Wifi router higher by 4 feet to get better coverage but it was no use (it’s at RSSI -48)

Then I took my working Doorbell Pro from my house and installed it on hers, the same problem.

So the problem could be the house chime or the Wifi or something else.

Some things I could do:

  1. Bypass house chime (digital)
  2. Toggle between digital and physical chime on the app
  3. Add a Wifi extender
  4. Turn all other Ring floodlights, and webcams off
  5. Replace Wifi router with more capacity

Anything else?

Hi @easyroc75. This thread has all the troubleshooting steps I would recommend for this type of concern. If you have tried these troubleshooting steps and are still having the same concern, give our support team a call for further assistance.