Live view doesn't work after someone rings. Ring Pro goes offline.

I’ve been having an issue with my Ring Pro doorbell where I cannot access the live view once someone actually rings the doorbell. I can access it otherwise just fine (opening live view after motion alert, or just randomly checking live view). Video is recorded and saved of a person walking up to the door, but as soon as they press the button the video cuts off and I get no more video. It actually appears the doorbell goes offline after that and doesn’t come back online until some amount of time later. Previously this functionality has worked as expected, but not as of late (I don’t know an exact time it started). I use both the regular Ring app as well as Rapid Ring, same inability to access once it’s been rang with either app.

3 Likes

Hey @crispy! If your Doorbell Pro is seemingly falling offline after a ring event, this can be a common symptom of low power. To confirm that sufficient power is making it to the Doorbell Pro, please check the following:

  1. Transformer is rated for 16V 20VA or higher.
  2. Wiring is not too thin, corroded, or spliced Cat5 wires
  3. Chime kit is Compatible and set properly in the app (mechanical or digital)

I hope this helps! :slight_smile:

I have auto-update on for may apps, and I suspect my Ring app updated recently (or my iPhone IOS did). But suddenly my Ring doorbell live view gets nothing but a black screen. History can be viewed just fine. Very weird. So I “chatted” just now with online support, and he suggested I try Rapid Ring (which I’d never heard of), so I downloaded that App, and it worked just fine! It is a stripped version of the Ring app, and only seems to do this one thing – answer the doorbell, or do a live view. I asked the chat guy if this was my permanent solution, and he said yes (!). He said what was going on was, and I quote:

“If there are interference with the signal the live feed needs a lighter version for it to work. That is why Ring provided a solution which is the Rapid Ring.”

So I asked if this were a known problem then, and he responded:

"It is not a know problem, but Ring made advance solution for it. "

This sounds ridiculous to me, and I suspect Ring had a bunch of bugs to figure out in the main App, so invented the stripped version. But this is the solution. For one thing, anything that speeds up the live view after someone punches my doorbell is worth it, as it took too long for it to come up. So I suppose I get something better from it. I still need the regular Ring app though for looking at history, managing other devices (I have the Chime, for example), looking at battery percent, etc, etc.

I am having the same issue as well. When someone rings the doorbell I cannot view it immediately. I must wait a few minutes before I can see who is (was) at my door which makes the device useless for real-time answers. Also, if someone rings the doorbell then presses it again within a few seconds it will not work. It is as if it needs time to reset itself. I believe it is a software glitch and nothing to do with power or wifi capabilities since it has worked fine for me the last 2 years. Now out of the blue I am having these issues. I am going to download the Rapid Ring app and see if that helps any.

When it happens on mine, my doorbell literally will go offline, and as you mentioned seems like it has to restart and is completely unavailable for a few minutes until it comes back. In that case Rapid Ring will not work either.

I agree on a software issue. Had no issues for about 2 years, now it’s junk. My doorbell is stuck on firmware version 2.1.01005 (does not say “Up-to-date”). Not sure what the current firmware version is, as I don’t see Ring publishing that anywhere. It has a strong wifi connection and voltage says “Good”/4022mV.

I haven’t had much time to mess with mine but hopefully will soon. If you get yours figured out please let me know, I’ll do the same. If someone at Ring could actually be helpful… please also feel free to chime in.

My live view stopped working when I was at home and connected to the same wifi as the Doorbell Pro. This confused me because it had worked for over a year. It stopped working on my iPhone, iPad, and the Windows app on a computer hardwired into the router. Both the Ring app and the Rapid Ring app would not show live view despite that fact that the Ring app would later show the Live View in the time line. The Live View still worked on the iPhone when it was connected to cell service.

I tried all the things found on the community discussions of reloading apps, testing internet speeds, static IP address, etc but nothing seemed to work. Out of desperation I logged into my modem and lowered the security of the Firewall to allow peer-to-peer (P2P) connections. This fixed the problem! I must admit that it may have been me who raised the security level of the firewall at some point and did not realize that it killed Live View at the time but I’m not sure if I really did or not.

1 Like

I have the same issue all of a sudden. The doorbell goes offline for approximately 8 minutes and then comes back normal. My doorbell is hardwired and I have used the Chime and ChimePro with out issues until recently. I do not believe it has anything to do with the power to the doorbell.

I spoke w a Ring rep for over an hour and the only culprit he could suggest was my WiFi was overloaded w so many devices throughout my home that when the Ring doorbell is activated it needs time to find the WiFi signal again through the all the traffic. He recommended getting a WiFi mesh System and see if that helps. I have not tried that recommendation so can or cannot verify if it was the solution or not. Hope this helps a little.

1 Like

I have an Eero mesh system for several years now. When I first installed it, they suggested the doorbell gets put on the Guest network. That is where mine has been ever since. And yet, I still have the problem where the live view disappears for at least 8 minutes. I downloaded the Rapid Ring app today and will play with that to see if there is any difference.

I would be curious to see how that turns out. It’s a shame that you have to use a third party app and/or mesh system to rectify the problem. Honestly I think it’s something Ring did w one of their updates like a year ago. It worked perfectly one day then one day it didn’t. Plus I had to get the Ring extender chime for $50. I put in $300 on a system that doesn’t work as it claims it does. Such a disappointment.

I tried Rapid Ring, but was still unsuccessful. I wonder if this just for the original doorbells or if the newer models have the same issue. Anyone have any input on that?

Thanks!

total BS

For what it’s worth, my doorbell no longer does this (I’m the OP). I just got frustrated with it, accepting the fact that my “video doorbell” doesn’t work if someone actually rings the doorbell and figured I’d move to another vendor once I got around to it. I have never rewired anything (so much for Ring’s suggestion of power issues), haven’t changed my network at all (I’ve had the same mesh wifi system since day 1 of Ring install), nothing. It no longer seems to do it though… which I’m sure I’m going to regret saying that out loud now.

This would seem to me as though it was a software issue. Hopefully all of yours will resolve itself as well. I would tell you what firmware it’s on, but it only says “Up to date” with no ability to view what the actual version is (insert eye roll here).

2 Likes

Actually I’ve noticed the same. Recently I immediately checked my Ring app as well through my Alexa Show and it was able to show me who was there in real time!! I was amazed. Like u said we may be jinxing ourselves but hopefully the issue has corrected itself for now.

1 Like

Now all of the sudden I am having this issue again. When someone rings the doorbell, the video feed immediately freezes up. I also noticed that if I turn on live view and then turn on the mic and try to speak, it also immediately freezes up. It seems like the camera has to re-boot after this, as it takes quite a few minutes before I’m able to access it again. All recordings stop immediately once the button is pressed, or the mic is used.

This is the most frustrating “security” camera I’ve ever had, and the off and on issues from Ring are unacceptable. Would really be nice if someone from Ring would chime in here and offer some sort of support.

1 Like

I am having the same issue again (Dec 2, 2020) as well so this proves it’s a software/firmware issue. I tried answering a ring just yesterday and that’s all I got was the spinning blue circle that eventually timed out. It was working fine for the past few months. Now it’s back to the way it was months ago. Like u said, so very frustrating and Ring continues to blame it on the WiFi. It’s a firmware issue 100% certain now. Plenty of other doorbells out there today; time to get rid of this p.o.s. and get something more reliable. My one star rating on Amazon will stay.

Hey neighbors! If you’re having persistent concerns with the Live View not loading properly, I’d suggest checking out our Community Posts on RSSI and Live View concerns first. If you’re not able to find a solution there, then it may be best to follow up with our support team directly. You can give our support team a call at one of the numbers available here. They’ll be able to take a deeper look at your account and device to help you isolate the cause of the problem. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile:

I have ring doorbell and can’t get them to live view video on my phone sent 11/ 20/ 20 help me out please 3 doorbell. 1 camera and doorbell chime

Thanks but I’ve already have spent hours on the phone w the Ring support. The problem is the software/firmware but Ring doesn’t want to admit there is a problem on their end.

I think I started this thread months and months ago. And maybe the “solution” scrolled away. But I have had no problems ever since I installed the Rapid Ring app (in addition to the Ring app), and had that one be the default when someone rings the doorbell. Works every time. I still need and use the regular Ring app for looking at history.