Live video not working - Your Phone is Having Trouble Connecting to Ring


Live view is not working for me from last year…I keep getting “We are having trouble connecting to your Doorbell”. Everytime I try to work on fixing it I fail. I checked the below Ring article

Followed every step, download and upload speeds for both mobile and Ring greater than 60Mbps. Ring signal strength <50. What can I do more? Tried contacting Ring many times with no hope…anyone with similar issue and fixed it can share his experience?


Messages I get attached

I tried everything possible. Used my TP LINK router wifi 2.4GHz, android hotspot, iPhone hotspot. Setup goes very smoothly, Ring can detect motions, but clicking to check the video dont work. Live view doesnt work. Always get the same error…“Your Phone is Having Trouble To Connect to Ring”. RSSI -45…Tried live view from Galaxy Note 10 Plus and IPhone 7S and both gives same error…Tried changing router channel from 1 to 11…no luck…disabled phone Bluetooth…removed data saver…How can I get this thing to work???

I have been having the same issues; I think I am just going to call; I have looked everywhere but not finding solutions; only those with same issues.

same issue. they told me all is good on both ends so i just have to buy a new one because im out of warranty.

Actually am afraid to buy a new one and face the same issue again…The problem is that I tried from Galaxy Note 10+, iPhone 7S, Galaxy A7…tried from Samsung Smart TV (smartthings)…tried from ISP and ADSL…nothing worked…so its not about some configurations for any device…there is something wrong either from Ring side or from Doorbell itself…If anyone had the same issues and found a solution plz let us know…

Any possible help?

Re: Live video not working - Your Phone is Having Trouble Connecting to Ring

Re: Live video not working - Your Phone is Having Trouble Connecting to Ring

I have the same issue and I believe my problem has nothing to do with internet or routers , etc. I have an android phone and I believe that it has to do with how the program works with my android phone. When I get an alert that there is motion, if I click on the alert message it will try to open ring and then not open. If I then click on the program I will get the message that it can’t connect to my camera. If I don’t click on the motion message and just go right into the app from the icon, I can connect. It is this way 100% of the time with whatever way I do it.

Hi @JAW1973. This could be due to some apps on your Android that are conflicting with the operation of the Ring app. We have a list of some apps that are known to cause such issues that can found here. I would also make sure you have your location turned on and disable any VPNs you might have active. I hope this helps!

What about Accubattery?

Hey @JAW1973. It’s possible that this could be conflicting with the Ring app. Try disabling that app to see if it makes a difference. Feel free to let the Community know if it helps!