Light Schedule not working

I have just installed a Ring Floodlight and want to set the lights to turn on at 6 PM and off at 7 AM. Setting the schedule is straightforward and I made sure to save the schedule with a new name. My location is correct and video activity is properly time stamped. However, the lights do not turn on as scheduled. Anyone have any ideas or tips. The lights do turn with motion.

Thanks in advance.


Mine isn’t working either. Looks like my firmware is out of date and apparently you need to call them to force a firmware down

On the Device Health tab, mine shows the firmware as up to date. Are you saying that it may still require new/different firmware. I did call Ring Support, but am not getting a warm fuzzy feeling regarding level one expertise.

I’m having the same issue.

Its driving me absolutley nuts.

I also cant get my firmware to udate on my Flood Camera and one of my Pro Doorbells.

This Floodlight might be going back in the box to Costco.

I am having the same issue. They seem to come on and off by themselves… They were supposed to come on by the schedule at 5pm and when they weren’t on by 6pm I turned them on manually and get a pop up that says the light schedule was interrupted. Then when I look out at 8:15pm, they are back off again. When they were supposed to go off at 7am and they weren’t off by 9:30am, I turned them off manually again, and again get the pop up that says light schedule interrupted. Two hours later I look outside and they are back on. Turn them back off and again get the pop up saying the light schedule was interrupted. This is driving me friggin nuts!!! I’m so close to ripping the darn thing back out.

I was having the same issue with my floodlight Cam so I changed my light schedule to turn on at 11:00 pm (GMT +0) which is 5 hours ahead of where I am (GMT -5 = 6:00 pm EST), and that worked. I called Ring and asked them to adjust the timezone for the device on their end in the system because it was not something I could change on my end. At first they indicated that I would need to adjust the timezone on my phone for the light schedule to work correctly, but I just verified that my phone is correctly displaying GMT -5. Once they finally made the adjustment on their end my light schedule correctly turned on at 6:00 p.m. ** Heads up, the call took 25 minutes and I had to explain the situation a few times. **


I have 2 floodlight cameras on the back of the house. I have them set , for winter, to come on at 5pm and go off at 7am. The floodlights turn off too early at 6am.

Where is the floodlights schedule getting their time from? Shouldn’t this be localized to the persons location? Synced periodically with the phone apps time?

For a company selling iyts products across North America and i assume beyond and across multiple time zones this would have been an automatic feature to have added in the app or system. If it is its impossible to find and i have looked for it.

@Canuck, agreed and there’s no feature within the app to set the time zone. Ring will tell you that their devices sync with your phone and for the most part that’s true, but with the floodlight Cam even though my time stamp was correct they had to make an adjustment on their end in the system for it to recognize GMT -5 (EST). It seems to only be recognizing gmt + 5 which is Pacific time if I’m not mistaken, and that’s their local time. The weird thing is that this floodlight Cam is a replacement for my original one which worked perfectly fine so I’m not sure if maybe the software is outdated in these newer floodlights or a change in software occurred that threw everything off to Pacific time.

Maybe give CS a call and let them know that they need to make an adjustment to the system because it’s not recognizing your local time zone despite the time stamp being correct and in sync with your phone :frowning:

I am having the same issue Floodlight schedule off sync. Maybe a month now. I even removed the device from group and started from scratch. No luck! Any suggestions much appreciated.

Hi BrawlerBella (love the name btw), what time zone r u in? If ur on the East Coast try setting your time schedule to click on at midnight. If it turns on at 7 o’clock p.m. EST, then you should probably call customer service and have them adjust the time zone in the system.

I am having this same problem. Did you learn of a fix?

Hi I was able to fix it by calling customer service and asking them to adjust the system time. If you read my entry further up, for me it was an issue where the time wasn’t syncing on the system. The flood light cam synced perfectly with my phone (because the time stamps were correct), but there was something in the background that was still syncing to Greenwich mean time instead of Eastern time.

Morning, I took your feedback and called in.
It was exactly what you shared. Very helpful, thank you!

1 Like

How exactly did you achieved that? Did they fixed it over the phone? I called today 3 times and spoke to 3 different representatives… no one of them had the knowledge to resolve this issue. I told them that the "light schedule is offset by 5 hours " Any help will be appreciated. Thanks!

Hi Vbykov, When you call customer service let them know what time zone you’re in. It seems that the floodlight Cam on the back end was set to Greenwich Mean Time (GMT +0) instead of GMT-5 which is the conversion for EST where I am. So when I set my schedule to turn on at 6:00 p.m. EST it wasn’t automatically turning on at that time, but when I set it for 11:00 p.m. EST it turned on at 6:00 pm. Also let customer service know that your phone’s time is syncing correctly to your time zone because they may try to insinuate that the issue is with your phone and not the Ring app. Hope this helps.

1 Like

Hi, it’s a time zone issue, which only they can adjust. Ask to speak to a team lead if the agents can’t figure it out. They will adjust their time zone to sync with yours. :slight_smile:

1 Like

You have two choices: 1. Call Ring to adjust your device to your time zone in their system. 2. Just set your time as if you are in London, England (GMT +0). For example, I am in Pacific time (GMT -8) so for my light to go on at 6pm, I set the start time to 2am. Problem solved. Ring MUST be aware of this so I anticipate this getting fix sooner or later and we will have to change the settings again. :frowning:

1 Like

I was experiencing the same issues with my Floodlight Cams, and came to this forum for information. I am on the east coast and both my floodlight cams had the wrong GMT set. This as I understand it was recently caused by several firmware updates. Unfortunately, getting the issue resolved involved a bit harder work. Harder in the sense of getting customer service to understand the issue AND not continuously claim its your phone causing the issue AND that they had no control over it. Eventually, I was able to get connected to a Level 1 Supervisor who knew of/found the UTC Offset setting. This is the location the customer service tech needs to go to update/correct/modify the GMT time. In my case (east coast) they changed it from an offset of 0 to -5, which did the trick and corrected all the light schedule problems. Good luck in dealing with Ring.

1 Like

Transformer lights don’t turn on based on schedule that is turned on for each day in the app.

I can switch them on through the slider all the way to the right in the screen.

If I try to change the schedule I had previously setup and press Save, nothing happens. If I press < a popup box asks if I want to “Leave without saving” or “Keep Editing”.

Hi gborn, Try going into your ring app settings under storage and clear the cache to see if that resolves your save issue. if not, go back into settings and force stop it. If neither of those 2 work, try uninstalling and re reinstalling the app.