Kwikset 888 locks are paired but do not work

I just set up my gen 2 alarm system (base, contact sensors, motion detectors, cameras, and smoke/co detectors). I added each of my previously purchased Kwikset 888 door locks. I factory reset each lock prior to adding because I had them linked to a different alarm system. I added all four locks successfully to Ring. When it came time to give access to each user I was unable to give access to anyone, including myself. I could not reset the access codes on anyone. The status under each lock shows “unknown.” I cannot lock any of the door locks through the app either. I tried adding a code through the lock first and seeing if that helped but I had the same issue when not adding a code first through the lock. All the batteries are new in the locks as I just put them in. Anyone have any ideas on how to fix this?

Hi @Motortendy33! The Kwikset 888 is a compatible lock that Works With Ring, and it should certainly be operating how you are intending to use it. I recommend removing and reinstalling the Ring app, and then trying to add the locks again, one at a time.

In regards to adding users or PIN codes, once you offer a Shared User access to your system, you will be asked to create a PIN code for them. That PIN code will work for both arming and disarming the system as well as accessing the integrated lock.

Check out our help center article for more information on Works With Ring locks. Feel free to let us know how the above goes! :slight_smile:

None of those suggestions worked. I’m still getting the error messages for the locks as pictured.

Having the same/similar issues here. Just set up gen 2 security system and connected the kwikset 888 locks, which worked, but cannot send user codes/ see status/ control the locks.
Mine show as unknown rather than error.

Would really like a solution to this. I’ve tried reinstalling the app, factory resetting the locks, restarting the base station, removing and reading the locks multiple times with no luck.

I’m still having no luck. I’m going to have to get with their tech support and press the issue.

Let me know if there’s a way for me to chime in too :slight_smile:

Not sure if this will be any help to you. I’ve contacted ring support who say the lock has ‘anti-theft’ enabled, which is why ring canon talk to the lock.

Turns out it’s something enabled by the previous security system, in my case vivint.

I was able to fix the issue by removing the lock from ring system. Re-adding to the old security system and then ensuring anti theft was disabled. Removed again from the old system and then re-added to ring and it works!

If you were using vivint before, I followed steps here:

When it prompts for a pin code I used 2203 though some seem to suggest you may need to call vivint to unlock this feature.

Hope this helps you and anyone else in this position :slight_smile:

1 Like