keypad stopped working

My entry keypad has stopped disarming the base station when I type in the keypad. This morning the stupid alarm went off, because my phone was updating the Ring app when I tried to use it instead.

I’ve called support about this and they had me factory reset the keypad. That causes the keypad to work exactly once. After that it doesn’t work again. I usually don’t have as much of a problem using the keypad to arm the base station. There is often a delay of 5 or more seconds between the time I punch in all the buttons and the time the base station seems to receive the signal. But when trying to disarm it, the base station doesn’t ever receive the signal. Anyone know how to fix this?

Hey @bsabiston. Do you see anything in the event history for your Base Station when you try to disarm your system via keypad? I recommend to go up to your keypad, put in your 4 digit code, then hit the arm button. Once it is armed, put in your 4 digit code and hit the disarm button. If this is still failing, you can go into the event history and see why it failed. It will tell you in the Base Station’s event history page if the pincode was incorrect, if it has trouble communicating and so on.

Also, sometimes when you re-add the keypad, or this may have been the case before, the firmware may need to be updated again or have been updated in the first place! You may have had a firmware update to the keypad this morning after you’ve re-added it. If you can, check for this update in your Base Station event history log as well. :slight_smile:

Thanks - I will try that if it happens again. This morning I called support and they said that my keypad needed a firmware update. They seemed to think that was probably the problem. So hopefully after updating the problem is fixed, we’ll see.

1 Like

Welp - that firmware update absolutely did not work! Now the keypad will not arm or disarm. The base station event history shows nothing, which isn’t surprising, because it seems like the keypad isn’t communicating with the base station at all… :frowning:

@bsabiston Is the keypad making any noises or saying “armed” or “disarmed” when you put in your 4 digit code and select a mode? If you’ve tried this a few times and the keypad is still unresponsive, please try pressing and releasing the pinhole in the back with a toothpick or something small, and then give the code another try to arm/disarm. If this continues to fail, definitely reach out to our support team here for a followup!

The keypad beeps when I press the numbers, but it never starts flashing red or says armed or anything like that. Yeah I’ve done the reset with the paper clip several times. After a reset, it usually works once, but later when I try it again, it is unresponsive.

@bsabiston Ahh, that’s definitely not good! I apologize again that the keypad seems to still not be able to communicate. Let us know if the support team was able to diagnose this further, or was able to issue a replacement if they were unable to help fix it!