Keypad not connecting.

One of my keypads worked fine for about a week, but now it won’t connect to the base station. I have tried reconnecting it. I have reset it to factory and then tried to install it. I uninstalled it from my system and tried reinstalling it. Nothing works. I start the install process and it flashes all its lights like it’s installing and then nothing. Can anyone help?

Sounds like possible distance or battery level concern. Our best recommendation given the information you’ve provided would be to leave it plugged in for a charge and also bring it closer to the Base Station. Once you feel it is sufficiently charged, please remove the Keypad from zwave by following these steps:

  1. Visit your ‘Devices’ in the Ring App
  2. Tap Alarm Base Station
  3. Tap the device that you want to remove (Keypad)
  4. Tap cog wheel in top right corner
  5. Tap ‘Remove Device’
  6. Tap ‘Remove’ and when app says “Listening for device,” hold the “1" key for 5 seconds

Once completed, attempt a new setup on the keypad. If issues persist, please reach out to our support who will be happy provide more in depth information pertaining to your specific scenario.

Hey @Dstew267 , hope all is well! Wanted to ensure your Alarm Keypad is operational and that the steps in my previous reply were helpful in resolving your concerns.