Keypad Chirp

Ok, this is driving me mildly insane.

I have enabled chirps - At the moment, as a test on one of the door sensors.

In the “Chirp Tones” menu it says: “Your Ring Alarm Base Station and Keypad(s) will sound this tone when the sensor is triggered” - So I have set that to a tone and when the sensor is triggered, the base station chirps, and the keypad stays completely silent.

So I asked the FAQ! It won’t let me post the link but it’s on the ring support site under articles - 360026671732-Ring-Alarm-FAQs

> How do I change the volume on the keypad? Does this also change the volume for the Siren? Can the keypad play chirps?
> Like the Base Station, the Siren will always play from the keypad at max volume.

It’s a little vague, but implies that the Keypad plays chirps - So the app tells me the Keypad plays chirps, the FAQ indicates that the keypad plays chirps - But the keypad doesn’t play chirps.

So - Does anyone else’s keypad play chirps, or are they lying to me in order to send me completely nuts and waste hours of my time resetting and re-registering keypads?

I’ve only set my Ring alarm up yesterday so I’m definitely still learning it but my keypad does not play chirps either. it does speak the “armed” and “disarmed” prompts. I also read the documentaiton as you do - that the keypad is supposed to chirp.

1 Like

Same here, no chirps at keypad. Sent me a replacement keypad and still no chirps. Sounds like they put the carriage in front of the horse. Hopefully an update will follow soon.

1 Like

At this time, only the Base Station will play a chirp each time a sensor or motion detector is tampered. The Keypad will play entry/ exit delay tones as well as sound a Siren in unison with the Base Station if triggered. Our team is definitely working on adding this feature and more to the Keypad - we will certainly keep you informed of any updates :slight_smile:


Could you maybe put that into the documentation? Apparently I am not the only one who read it and believed it - I checked before I paid up, and it’s one of the major reasons I bought the system because I wanted to know when people walked into the workshop.


I installed my alarm system a few weeks ago and on entry the base station chirped a couple of times immediately followed by a couple of chimes on the keypad. I haven’t changed any settings but the last couple of days the keypad no longer chirps. I don’t understand why Ring cannot produce a comprehensive manual rather than customers having to search through a numbe of links that normally end up with frustration and no soluton.

1 Like

Hey neighbors! I’m happy to announce the Keypad chirps are now available to toggle in the app. If you visit the Alarm devices page in the Ring app and select the Keypad, there will be a toggle for Keypad Chirps that you can enable. Try uninstalling and reinstalling the app if you do not see this feature. I hope this helps! :slight_smile:


I Hear the chirps from contact sensors but nothing from doorbell press. My keypad is in a central location downstairs where it would be awesome to hear doorbell press. The base station is upstairs in a guest bedroom near the router. It’s got the hardware capability. I’d hate to have to buy a chime when I know the keypad can do it. Is this in the works as an update? Or am I missing a setting?

1 Like

What about the base station? None of my contact sensors are triggering the base station to chirp even though everything is set up properly. Everything has been working fine for the past year until today. Thanks in advance.

@RingUser18 Your Alarm Base Station should also be chirping. You may just need to adjust a few settings so you can hear this. First, check if your Base Station has the volume up loud enough. You can do this under the main menu > Devices > Alarm Base Station > Base Station > Audio Settings (make sure it’s turned all the way up and hit save at the top right).

If you still are not hearing the chirp when opening and closing a door, let’s make sure the devices are set up to chirp! You can do this under Devices > Alarm Base Station > and then any Contact Sensor. Once you select a sensor, you will need to make sure under Chirp Tones that it’s not set to none. After this, go back into the main menu > Settings > Modes > Disarmed and make sure Enable Chirps is turned on.

Hope this helps! :smiley_cat:

My setup worked as it should for the first 6 months or so. After that the keypad stopped chipping. It also doesn’t sound the alarm anymore. The alarm sounds out of the base but not the keypad. That went on for a month and then the base stopped chirping as well. The base still sounds the alarm, but no chirping. I’ve uninstalled/reinstalled the app, reinstalled the devices, checked setup for the devices which was correct according to the above post and nothing still works… Sounds like there are many people out there with the same issue and no working solution/fix has been made. It’s a brand new system. I’m not buying a new keypad and/or base station. I’m hoping Ring will right their wrong. Other than this, I have been a happy customer with the products.

Mine is the same, the speaker in the keypad is broken, I can hear a pathetic clicking as it tries to beep. My phone beeps fine so the system is working, just the keypad is broken. I reported it online as a warranty issue about 2 months ago but Ring are now completely ignoring me it seems. I am just sick of this useless system.


I see this post was created by RIng Support back in October of last year talking about Chirp support for contact sensor devices to the keypad. Seems a lot of people are having the same problem 10 months later where the keypad has the chirps for a short amount of time (in my case 8 days) tthen seems to die. Is anyone at Ring Support do anything to resolve this issue? I’ve checked all my settings and they haven’t changed since it was working 8 days ago. Sounds like a firmware fix is needed to resolve this problem.

Hi @luckylono! Your Keypad chirps should still be working as intended. If charging the Keypad did not resolve this, and your Keypad and Sensor chirp/ volume settings are optimized, chirps should be operational.

It is possible your Keypad needs to be reset, if the above did not resolve your concerns. Check out our help center article for steps on how to remove/ re-add and reset your Keypad. Feel free to let us know how this goes! :slight_smile:


Thanks for the quick response. Unfortunately it did not resolve the problem. Just like before, when you open a door instead of a Chirp/Chime all I get is a few clicking sounds which sound like static applying power to the speaker similar to what you get with a loose connection. Also I no longer get announcements when the mode changes and it no longer lights up when I walk by it, which it always did in the past. The device currently has power to it. It is not running on battery. The base station does get the correct Chirps/Chimes and announces system mode changes. The key pad currently sits mid way between the base

station and a Ring network extender. The base station is less than 12’ from my router and less than 20’ from the keypad. This is really beginning to sound like a hardware issue. Any direction on how to proceed from here would be appreciated.

Hey @luckylono. Chiming in for Marley here! It definitely sounds like your Keypad’s speaker is no longer functioning as it should. Rest assured, our support team can take care of this for you. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Please feel free to come back and let us know how this goes!

If I have 2 keypads, Can I toggle chirping on 1 keypad and NO chirping on the other keypad?

Hi @wrc520. Yes, you should be able to go into the settings in the Ring App for each Keypad to toggle the chirps on or off. The settings would apply only to the Keypad that you changed them for. I hope that helps! :slight_smile:

1 Like

I have a keypad in my kitchen and a keypad on the lower level of my house. This lower level is where I foster dogs. I have a door sensor on the door on that lower level that leads the dogs to a dog run. My question is, is it possible for that keyboard to only chirp from the sensor that is on the lower level door and not have the other sensors audible down there. The keypad is playing the chirps from the upstairs sensors and waking the dogs up at night when my teenagers come home late.

Hi @wrc520. There is not a way to enable your Keypad to play Chirps from only one sensor, and not others. When the Play Chirps option is toggled on, all chirps would be played. If you have an Alexa device, you could setup a routine so that a sound is played when a specific door opens. I hope this helps!