Keypad and contact sensors can not connect to the network

I purchased the 1st gen ring security kit from Costco last year and tried to set it up recently. However, only the base station works fine (the app shows it is online but I wonder if it actually works correctly). Both keypad and contact sensors can not be set correctly. The error message on Ring app is “waiting for connecting to network”. I’ve tried all methods provided by Ring Help Center such as “plugin/unplugin power”, “factory reset”, “remove z-wave device”. I wonder if there are other methods I can try to set the keypad and contact sensors.

Hey @davidxu06. Could you try removing the devices, resetting them and then trying to re-add them as you would other devices that weren’t automatically linked? Sometimes manually added them instead of trying to connect them through them showing up as kitted to the Base Station will help. You will have to remove each device that is waiting to connect individually and then add one by one, but this may work!

To remove each device go to the Main Menu > Devices > Alarm Base Station > select any keypad or sensor to remove > Gear icon at the top right of the device page profile > Advanced Options > Remove Failed Device > Remove. Once removed, perform the reset on the device as stated here. Once reset, bring the device near the Base Station. For any device that is battery powered, take the battery out and leave it out until the app will tell you during so during set up. For the keypad or range extender you may have, keep them unplugged. Go into the Main Menu > Set Up a Device > Security Devices > and then select the device you have and follow the in-app instructions.

From there, you will get to a page that will say “connect your devices.” On this page you will see the Contact Sensor, Motion Sensor or other battery operated devices state “pull the tab,” but since you have already done this, you will be putting the battery back in! For the Keypad and Range Extender, it will ask you to plug it in which you can do then as well. Ensuring you are still near the Base Station will make the connection at this part very easy for you.

If this continues to fail or you run into a roadblock anywhere, please reach out to our support team here via for more advanced troubleshooting. :slight_smile: