Issue with wired Ring 2 doorbell

My Ring 2 doorbell has been working for some time with no issue, it is wired into mains, but a few weeks ago we noticed it wasn’t working, no lights when pushed or anything when I press the setup button. I took the battery out, charged it for a bit and the doorbell then worked again for a few days, then I noticed the same issue has occurred. Looking at the device health it says that it is offline, hardwired, and that battery level is 100%, I’ve charged the battery a couple of times and this fixes it for a couple of days.

As it is hardwired and the device seems to be registering that it is hardwired and no loss of battery - what could the issue be?

Hi @hales8181. If the batter is fully charged and the Doorbell has a stable wifi connection, it should remain connected and responsive. Have you tried resetting the Doorbell? If not, I’d recommend doing so by holding down the setup button for at least 20 seconds. If this continues to happen, please give our support team a call at one of the numbers available here. They can take a closer look for you and help determine what may be causing this. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.