Issue with Ring Floodlight Cam setup - lights on constantly - offline

I was just installing a Ring Floodlight Cam. It’s the 3rd one that I have installed overall and never had issues. I already had an electrical box for it pre-wired by an electrician. So I connected all the wires and mounted it.

It turned on initially and everything seemed fine. I went through the setup, it connected to my WiFi and had very good signal (RSSI -45), I could see the video initially. Then I heard the voice prompt that it was doing a firmware update and wait until the LED stopped flashing. That is when the issue occured. Both of the floodlights turned on and stayed on. Device went offline. The setup LED at the bottom wasn’t flashing.

I left it like that for 10 min and same thing. I turned the power off and back on. Same thing.

I tried the setup again and pushing the button at the top - nothing. Tried holding the button down for 15 seconds - nothing. It won’t go into setup and the floodlights stay on.

When I kill the power and turn it back on I can see a row of red lights turn on for a second on the camera and also the light at the bottom flashes green very quickly but thats it.

I have a feeling that the update somehow broke the device.

I am in the process of exchanging it but want to see if anyone else had this issue before?

Also want to make sure its nothing that I may have done wrong.

Thanks