Issue connecting to wifi? Where does password go?

Hi I have just installed the ring video doorbell wired for my Mum, I have the same one and had no issues though it was some time ago… I am using a fire tablet with the ring app on (I may have used my phone for mine though not sure where I got the ring app on android as it’s not on play store) the camera is poor and it won’t read the QR code so I have manually input this, I gave up after the 6th time of it failing to connect.
The issue is it just hangs saying it is connecting to wifi (or doorbell) the wheel spinning and just doesn’t do anything, I left it for 10 minutes but cancelled it (just cannot imagine it could be more than 30 seconds to connect, though did read somewhere half hour ago it could take up to 30 mins, is this true?)
Is there any known issue with connecting the app to wifi?
The confusing parts are the app in going through set up comes up with these steps (screenshots)


r/Ring - Issue connecting to wifi? Where does password go?

It says get your Wifi password but I don’t see anywhere or any prompt to add this so I click continue…


r/Ring - Issue connecting to wifi? Where does password go?

This again, it says ‘when prompted’ but on this screen nothing changes, If I continue I believe it loops back to the screen before these 2 that ask if the doorbell white ring is spinning…
I have found if I hold the wifi symbol on the drop-down menu of the tablet there is a ring connection, clicking on that the door bell usually vocally says ‘now connected’ yet in doing that the tablet states of no connection to wifi? (as i’m switching connection to this temp ring one?)

I’m a little confused as to how this temp ring connection is used in all honesty.

Going forwards once it is connected it just hangs on the connecting screen with the on screen wheel spinning endlessly, I’d consider it could take more than 10 mins but I’m sure mine was quick and again I don’t believe it has my Mums wifi password either.

Where or when do you enter this? I’d have thought it would raise an error message also if that was the issue?

When it says when prompted connect to the ring wifi network is that on this page or after pressing continue? As I say it just seems to loop back to the ring circle spinning screen? (asking you to confirm that is the case)

In fact upon trouble shooting I saw a thread saying someone had this same issue and to delete the Ring on app storage and cache (worked for them) which I did twice and also disconnected the power and restarted the doorbell to find it just hangs again and again.

I’m wondering if the unit is faulty? (doubt that)
Or perhaps doing it without scanning the QR code is an issue? (though it accepts and states to enter the code as an alternative)
But mainly I’m thinking it’s more to do with the wifi password or the prompt to connect to the ring wifi? (why does it continue though and says it is connecting, am I just not waiting long enough)
Should I need to pull the drop-down wifi menu and click the ring connection manually? (It seems to just loop if I don’t)

Any help would be greatly appreciated


Hi @Granty1. I would strongly suggest using a different phone or tablet to complete the setup of the Ring device. Make sure the other phone or tablet is logged into the account you have created for your mom. Once the setup is complete, the Ring device will also appear on the Fire tablet where the setup was failing. Let me know if this works.

It was the tablet that seemed to be the issue, I kind of assumed with Amazon essentially being the company behind both devices and you know, how even amazon devices such as echos seem to know who bought them and be partially set up out of the box, that the Fire Tablet would work…
I think they should try to make it as so long as your on the local network and entering the QR code why wouldn’t it?
A company should do whatever it takes to avoid that kind of frustration…

I called the ring helpline and I’m so used to poor service but it was a breath of fresh air, she had me use my own phone as the app wasn’t compatible on my Mum’s (which is why I was using the tablet) log out of my own account and into her new one and with that the whole setup worked seamlessly, all missing prompts were there.

Even when I tried to let the advisor go she insisted on staying on the phone until I had it up on the tablet.

The only thing that was different with my phone and the tablet is that my phone camera picked up the qr code whereas the tablet camera wasn’t good enough to do so and so it had to be manually input…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.