iOS App freezing STILLLLLLL!

Hey Ring. Are you ever going to fix this or do I need to go to another company?

For weeks now the iOS app has been freeze when trying to view Nearby Incidents. I’m starting to get angry. This makes the main reason for having a ring moot.

How about fixing this!


Sorry to hear this concern is persisting @KevinR! Try removing and reinstalling the Ring app on your mobile device, as well as ensuring bluetooth and VPN is disabled while using the app. Feel free to include a screen recording example so we can assist further.

I don’t use VPN on my phone but Bluetooth disabled, REALLY?
Is your code that weak?

I’ll give all that a try but you folks need to fix your code so your customers don’t have to jump through hopes just to use the app.


Well now. All I had to do was delete and reinstall the app. Lo and behold it’s essentially a brand new app with new features that weren’t there even after the latest update. Yes I keep all my apps up to date installing the updates the day I get them.

Ok, I have a new problem. I can’t change the alert to anything other than chimes on my phone, iPhone 7+. The Alexa’s work great and do the announcements but my phone just chimes no matter how I set it. Also, I have new features and I can’t enable Motion Verification. I select Enable Feature , it says Enabled and it just reverts back to Enable Feature.

I’m absolutely sick of this happening as well. I’m considering a class action lawsuit

I’m having same issue. It’s freezing on IOS. I have to close the app numerous times before I get change settings or watch video. Extremely frustrated!!

Having the same issue with the app freezing. I am navigating within the app, it freezes at random. I am not even trying to watch the videos.

Hi neighbors. I would make sure that you are running the latest version of IOS. There has been quite a few updates recently. I would also make sure your Ring app is up to date and all the permissions are enabled. Lastly, make sure you don’t have too many apps running in the background, as this could slow your phone down. I hope this helps!

My iphone SE (gen 1) gets updates. iOS is 14.1, which was applied a week or so ago.

I use the Ring app daily on this device. This morning it would not run – sits there with Ring logo and blue background, then after a while, it simply goes away. Tried phone restart, tried closing most apps, etc. Then removed the Ring app, but my phone restarted. After that the launch icon was gone, so I tried reinstalling but the App store only shows Open, not Get. I see that there is still partial app, because going into settings, I see Ring but its icon is a wire-frame with no color. I can select it and get settings such as Background App Refresh, which is still turned on. After a couple of phone restarts, I could find a lauch icon by looking in the new App folder (a iOS 14 addition), and was able to select it and select remove, but that didn’t resolve – still can’t Get or Update the Ring app. I installed Rapid Ring and set notifications for it so I hope to get notifications. I really don’t want to Reset my phone. Should the Ring app update (reinstall) when the next version is pushed out? I’d rather wait for that for a week or so than doing a phone Reset. Better yet, if there is a way to manually remove the app (enough of it to allow App Store Get), that would be ideal. I’ve tried using the Apple suggestion of going to iPhone Storage to Offload app, but the Ring app doesn’t show up there. I called your tech support, your tech said to try calling Apple for support – wow! This isn’t an iPhone problem!

The Ring app version changed yesterday, so I was able to Update the app and it seems to be working (after clicking thru several offers to setup Modes).

1 Like