Internet connection is not currently working

I updated the Ring app on my iphone yesterday and now I can’t get into the app…it keeps telling me that my internet connection is not working…yet i have no other issues with other apps on my phone…My husband did not update the app and his is working fine.

I to have the same problem, was working fine this morning. Internet is on and good speed. Other apps working fine. Deleted Ring app and reinstalled, Now it won’t let me log in as it keeps saying ‘Your internet connection is not currently working. Please try again’. Yet again, my internet is fine, i can log in on my pc, just not my phone. Any advice is welcome. Thanks.

Hey neighbors! While making sure you have the most up to date app, you will want to make sure you have the most up to date operating software for you phone as well. This could be the cause of why you are unable to log in on your phone, but can from a desktop or browser. If you can, please make sure you are on the most recent iOS or Android operating system, and disable any VPNs that you have enabled that may be preventing you from logging in. Hope to hear back from y’all soon!

1 Like

This has done the trick. I was on ios 12, updated last night to ios 13, now all is fine. Thank you.

1 Like

Sent an email to them this morning regarding this very issue.

Ring app ver 3.22.1

Android 10 with security patch level Jan 1, 2020

Google Pixel 2 XL phone

Full network signal on phone

App has been working fine until this morning when I tried to enable the motion settings on my indoor camera. App froze, so I cleared cache, cleared storage, reset the app, uninstalled/rebooted/reinstalled the app from GPS, and it just freezes on the user login screen. No response from app and never logs in. Web interface is working just fine and I can play previously recorded video. Just seems to be the Android app that’s having issues.

1 Like

Since I have two Android phones at my disposal here at the house, I did a bit of testing. I dusted off my BlackBerry Key2 phone (Android version 8.1 + latest security patch), booted it up, and was able to use the Ring app normally. I then uninstalled the Ring app on my second Android phone, a Google Pixel 2XL (Android version 10 + Jan 1st security patch), rebooted the phone, installed the Ring app via the Google Play Store, set the necessary app permissions, logged into the app when prompted, reset all my home Ring cameras via the app, and all is right with the world again. It’s working now.

Maybe using the Ring app successfully on my spare BlackBerry phone did something to my account so that I was able to use it again on my Pixel 2XL??? I’m baffled, but at least it’s working.

TL;DR - Ring app working again.

I have this same problem. When I try to log in I get the error message “Your internet connection is not currently working. Please try again”. But all other internet-connected apps work on my phone. The device (Spotlight Wired) appears to be working fine - recording videos that I can view from my laptop browser. But I can’t log into the app. iOS is updated.

iPhone XS, iOS13.3.1

Hey @neeeeel, could you please attempt some of the solutions that have been offered as above in this thread? This may help resolve your concern. These solutions include removing the Ring app, rebooting your phone, and then reinstalling the app, or making sure any VPNs on your phone’s connection (turning off wifi and using data only) are turned off.

I tried a bunch of these previous and they didn’t work. But now tried switching to cell data and that works. I’ll have to try the wifi again when I get home. Thanks!

2 Likes

So I had the same error problem with app not allowing me to sign in and saying “internet not connected” issue, but I noticed that the old ipad I was trying to use Ring app was on a parental control setting because it was previously being used by my kids. I use Disney Circle and removed the Ipad from kids settings and that worked for me. For some of you guys, you might need to go into your router settings or the router app to see if the device you are using has restrictions.

1 Like

Your mention of VPNs is what worked for me. The Guardian VPN was getting me the “internet connection is not currently working” error message. I switched to my other VPN (yes, I’m cautious; I have two different VPNs) and was able to get in fine.

Can’t log in to ring says no internet connection what the hell is going on everything is fine

Ring seems to have done something to the app. It no longer works with Nord VPN. If I turn off the VPN it works but who wants to have to turn off the VPN to use a doorbell?! It’s always been a glitchy product. Ring now that you have the resources of Google behind you please fix.

Hey neighbors. Just wanted to clear something up for you, but please note that Ring does not allow the usage of VPNs for the devices to be connected under, as well as use Ring.com or the Ring app with a VPN. As of December 2019, we no longer support the use of VPNs while accessing Ring, Rapid Ring, or Neighbors applications. In order to use these applications, we ask our neighbors to disable their VPN or ask their VPN provider to help them exclude Ring traffic from the VPN. In addition, you may see a 406 error message displayed when you try to log in to a Ring app via a VPN.

1 Like

I spent 3 hours trying to connect and never did any of the ring help mention the VPN. as soon as I turned it off I got the abilty to connect. All is well now.

1 Like