Intermittant setup fault?

Has anyone else tried to set up their Stick up cam elite POE device yesterday? Saturday 7th? I had a power outage in my house, and so I had to run through the setup to reconnect to the temporary network from my device, so I could connect to my network. The device would only flash for 10 seconds (in setup mode, which was not enough time to connect (or find) the temporary network, and so setup could not be completed. I contacted support, and ran through the troubleshooting to no avail. They concluded the device was faulty. So I put everything back in its box to get a refund from the reseller.

The next day I thought I would try it again before sending it off, and it just worked, the device flashed for as long as I needed it to to setup the device. I am trying to establish if the issue was my internet or the device itself causing the problem, i… has this happened to anyone else, and if there is the potential for it to happen again.

EDIT: I just moved it back into its location outside, and no connection at all (It does work in this location - signal is good). So I removed the device from the app to set it back up again, and the issue of timing out during the temporary network re-occurred, and after doing all of the troubleshooting i.e. reset, etc the same issue persists. So I took it back into the house back to the router again, and same thing again as all of the above.

SO I have to send it back tommorrow as it seems ‘faulty’ and for my 30 day returns, but i suspect if i leave it overnight and set it up again in the morning it will work. Is there a delay in the account servers or something that is causing this?

Hi @user61464. We do not have reports of any sort of outage that would have caused this to happen. I would recommend following through with your return.