Installation Video Doorbell Pro (wired) Flashing Blue Top Half

Hello,

I, went through the process of installing the Ring Video Doorbell Pro. The unit is Certified Refurbished. My home is built in 2015. I confirmed that the chime (BK125LWH-1) is compatible via the list on the website. I measured the NuTone c905 transformer voltate was 22V.

I have installed the ring power kit and camera/bell module. The blue light on the top portion is flashing but does not seem to be progressing. The included instructions state up to 30mins; however, it has been about 60min and nor progress. How long does this take. Phone support said 24hours.

Ring sends you here for help on install questions but does anyone from Ring actually moderate/monitor this site? To answer questions. My Video Doorbell Pro has now been blinking blue in the top corner for about 6 hours. It is not progressing at all. How long should this process actually take?

Anyone? It is now about 18 hours and the blue light is still flashing on the top only. This morning I tried resetting using the side button and cycling the power down via breaker for over a 1 min. The light goes out for a bit then the white light circle shows up and flashes slowly then it is right back to blue light on the top.

Hi @IUHoosiers. Thank you for listing all the steps you’ve take so far. It appears you’ve covered all of your bases, but there is one thing I would confirm. What is the voltage rating of your transformer? It should be at least 16-24V, 30VA.

If your transformer does meet these requirements, I suggest following up with our support team for the next best steps. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.