Indoor camera stopped connecting to wifi

I have a 3 month old Indoor camera. It was working flawlessly. Suddenly it began to lose network connection. It would work for another 3-4 days then fail.

Now it will not connect to anything.I have verfied the power. when i plug it in to a verified working outlet it does light up and flashes blue for 1 second.

It does not ever enter set up mode and have the blue light flashing.

I have rebooted router multiple times, tried different outlets and different wifi/chime pro options All other Ring devices work fine.

I cannot find a way to contact actual Ring service for a hardware isue. I feel this is a warranty hardware issue.

I am having this same exact issue, did you ever figure this out?

Hey neighbors! If your Indoor Camera is not connecting to your wifi network, you may need to ensure you have the proper ports and protocols opened and adjusted to allow the Ring device to connect and stay connected. After ensuring the network is set up properly, please try resetting the Indoor Camera by pressing and holding the setup button for 20 seconds. After 20 seconds, make sure you go into the Device Health page and tap on Reconnect or Change Wifi Network, where you will go through another setup.

In the event the device still cannot even enter setup mode, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.