Indoor cam stuck in "activating device"

Hello I have 2 indoor cams One is working fine The other one always hang on the “activating device” message Tried to put it 2cm away from the modem Tried deleting it It works again for an hour then goes back DEVICE HEALTH is perfect with rssi -28

1- What shall i do?

2- And is there a way to reset it?

Hi @Shudukhi. You can indeed reset the device from pressing and holding the setup button for 30 seconds, and then it shall reboot from there. If one device is hung up in activating device, is then when you try to view the Live View right after an event has happened? The camera could be processing an event that just happened, and therefore getting a bit hung up in activating device. In addition, you can try using mobile data only on your phone to see if this loads the Live View faster, or even trying out the Rapid Ring app. Last thing to check over is your speeds at this time, primarily your upload speeds, as this is what is used the most during Live View. If all else fails and you still get the Indoor Cam hung up in trying to load the Live View, please let me know what your speeds are after going to :slight_smile: