Inability to add photos to new pet profile (possible defect)

I just bought the new Ring Pet Tag. I am following instructions to set up the pet profile, which I have to do before scanning the tag. I was given three permissions options when I clicked on Add Media (1 photo or video is required) and then “Library”. I chose “Add Photos Only” . That didn’t allow me to upload media. Now, the app is telling me to open settings and change the value to “All Photos”. However, there is no “All Photos” selection! All that’s there are “None” and “Add Photos Only”. So, since media is required, I am stuck and can’t set up my profile and, in turn, can’t set up my pet tag. Please fix! Thanks.

I am having the same issue! This is ridiculous!

1 Like

Hi Neighbors. What type of phone are you using and what version of the Ring app is installed?

I have the same problem. This is not ready for the public

1 Like

iPhone 13 Pro - very latest iOS and Ring app version as of Oct 11 23

Please see the other person’s comment. This isn’t just me - how can we get past this?

Hi Neighbors. I’m working with my team to investigate this. Can you share a screenshot or screen recording of the error you are receiving?

1 Like

If I click “Library”, it starts to pull up the photo library, then disappears and brings me back to this screen. Endless loop if you try again. So, you end up stuck and can’t finish setting up the pet tag.

Hi @buntery. Thanks for sharing that information. I’ve forwarded this to my team for investigation. Once I know more, I’ll update this thread.

Hey Neighbors. Try this:

Navigate to your phones settings and look for this option pictured below.

Toggle on the "All Photos " option and let me know if this changes the outcome.

That’s the other issue. I can’t. Notice - App Version 5.65.0 (more recent than yours). No option to select “All Photos”.

1 Like

1 Like

Hi @buntery. Can you also share what iOS version you have installed? I’m in communication with my team on this issue, so rest assured, we’re actively working on this for you.

Hi @buntery. For an additional troubleshooting step, try going to your iPhone Settings
→ Privacy & Security → Photos → Ring and ensure Ring has Full Access.

It shows the same options there too

Hi @user62118. Can you share a screenshot of this? Also, what Ring app version do you have installed and what phone/OS version? Thank you.

Hello! I’m having the same issues as others above. Bought two pet tags but can’t set them up. Only options are ‘None’ and ‘Add Photos Only’ and neither gives access to the iOS photo gallery. Since you have to upload at least one photo, it won’t let you bypass this in setup to setup the pet tag. Also tried going thru Privacy settings noted above but still same issue. I have iOS version 17.0.3.

I had this same issue too where I was stuck with this Add Photos Only option.

I deleted the app and reinstalled the Ring app. After reinstalling the Ring app, and selecting Pet Tag in the devices list, I was able to update my permissions to grant access to all photos

This solved the issue for me!

Hi neighbors. What @user63716 suggested is the troubleshooting step that we are recommending to do for this concern. Uninstall the Ring app on your phone and reinstall it. Once logged back into your account, proceed with setting up your Pet Tag, and when going through the setup, you will get the pop-up option to grant Ring access to All Photos. This should now allow you to pick a photo of your pet and complete your setup. Let us know if this works.

1 Like

That worked! I was able to update the pet profile with my photos. Thanks for the tip!

1 Like