In UK 3rd Gen Stick up Battery Cam Firmware fault

I changed the Battery when the cam was at 15% and the camera then wouldn’t come back online. The Blinking Blue LED Suggested it was updating Firmware even though the health report said it was up to date. 24hrs later and the camera still showed it was updating. I removed the Camera from the App and reinstalled it. The App showed the update up to 90% and then it just stayed at that for several hours. Tried again with various resets and it won’t update fully. Any Advise Please?

Hi @Monty2520. Try resetting your Stick Up Cam by holding down the reset button for at least 20 seconds. After the reset is complete, take the Camera through a new setup in the Ring app using the steps under Set Up a Device. If it still doesn’t complete the firmware update or gets stuck updating again, please give our support team a call at one of the numbers available here so they can provide more advanced troubleshooting support. If you are outside of the US, please visit here to see how to contact support.