In-home mechanical chime is ringing even though it’s disabled in settings for Ring Video Doorbell Pro 2

This issue started happening last week after an app update. Something is broken in the app because the “ring in-home chime” setting is disabled yet the mechanical chime instill rings when someone presses the doorbell.
The whole reason of buying this model was so that I can disable the mechanical chime (which worked great until last week).
Now my baby wakes up because of the mechanical chime setting is broken

Hi @user-52061. If you haven’t done so already, try toggling the In-Home Chime setting on and back off to see if that corrects this issue. One more troubleshooting step you can try as well is a quick reboot. The reboot option can be found on the Device Health page in the Ring app. Should neither of these steps work, I’d recommend following up with our support team to investigate this further.

Hi @Caitlyn_Ring , thanks for responding! Before I even posted the above, I tried both options you mentioned multiple times already and it did not fix the issue.

1 Like

This issue started happening last week after an app update. Something is broken in the app because the “ring in-home chime” setting is disabled yet the mechanical chime instill rings when someone presses the doorbell.
I already tried the quick reboot and toggle on/off the setting.
the issue remains.
Could the support team have a look?

Thank you

1 Like

I have a Ring Video Doorbell Pro 2. I have the in-home chime (mechanical doorbell) disabled intentionally, and that has worked flawlessly for years (even upgraded from Pro 1 to Pro 2 and have never had a problem). Recently, with no changes being made on my part, the in-home chime has started ringing again. I checked the settings, and the in-home chime is still disabled in the settings. What could be causing this, and how do I fix it? Are there any workarounds?

Hey neighbors. If the troubleshooting steps listed in this thread do not work, the next best step is to follow up with our support team for more in-depth assistance. We do not have access to device details on the Community, so our support team is better equipped to take a deeper look.

1 Like

After trying the above steps and calling support, we solved it by doing the following:

  1. remove cover of doorbell and perform hard reset
  2. change indoor chime setting from mechanical to “none”
  3. removing the jumper cable in the mechanical chime box
  4. reinstalling said jumper cable.

No idea why #3 and #4 were needed but after attempting ringing the doorbell after each step above, it only stopped ringing after #4. Good luck!


Having the same issue as above. It’s driving my dogs nuts lol.

Same issue, but this didn’t seem to resolve for me

Has anyone found a fix? I just got my ring doorbell pro 2. The in-home chime is disabled but still rings. Support was not helpful, they pretty much sent me an article to re-wire my home chime to disable it. Why not fix your app as that looks to be what the problem is from what I am seeing in this forum.

No fix for it. Looks like they’re not even acknowledging that they broke something with an update

1 Like

Can somone share a model of mechanical door chime that works - the compatability list is not working.

I’ve had the same issue, Ring support not helpful as usual. I found the following workaround resolved this for me: Under ‘in-home chime settings’ change chime type to ‘none’ instead of unchecking the ring in-home chime setting.

I was able to resolve, break and then resolve again so it was replicatable on my end. Hopefully this could help others.

I had chime type set as mechanical and unchecked ring in-home chime for a long time and recently it started chiming.

Fix: Set as mechanical and select ring in-home chime. Save. Confirm doorbell rings as it should. Then change to chime type to none. Save. Confirm doorbell doesn’t ring. If you set type none while doorbell is set mechanical and do not ring in-home chime, this fix won’t work so be sure to follow as instructed. Seems like a weird way to fix the glitch until Ring resolves the underlying issue but it worked for me.


It’s been a couple weeks since your last post. Not sure if you get notified of replies to your post so tagging you directly. I just posted a fix that worked for me. Good luck!

The above fix worked for me too, you are the man, made my life 100x better got a young toddler and it was waking him up from nap time!

This method worked for me!


This worked for me too, thank you!

1 Like

Your workaround worked! Thank you! Really shows how the Ring support team doesn’t know anything here

I’m having the same issue on a brand new Pro 2 installation and I spent about an hour messing with the power, uninstalling the Pro 1 box, rebooting, continually turning it off and saving it, getting super frustrated.

The only workaround (as has already be stated): you must SAVE it as ON with mechanical chime. Then you SAVE chime type as NONE. Any other combination of saving (for example if it is already saved as off) will not work.

This really does need to be addressed, I almost sent the silly thing back.

1 Like