I need the old App back

I have an older Iphone with 12.5.5 IOS. How can I reload the older App?

You can’t. The app now requires iOS 14.
You’ll have to update your phone or only connect via a browser.