I am beyond frustrated

On my second ring pro 2 doorbell in 2 weeks. 2’d one worked for 4 hours and disconnected. Upgraded to a 24 v transformer and I can’t get the doorbell to set up. Right now it’s stuck in set up mode but it won’t let me connect. I’ve gone through the all troubleshooting tips. It spins for a fraction of a second and then pulsates white. No opportunity to connect to the ring wifi. I am livid!

Hi @Angry6. A flashing white light would indicate a firmware update. I’d first suggest reviewing this Help Center article to ensure there is not an insufficient power issue. Upgrading to a 24 VAC transformer should have resolved any power issues though.

After verifying that the Doorbell has sufficient power, try fully resetting the Pro by holding down the setup button for 20 seconds. Once the reset is complete, attempt to walk through a new setup in the Ring app using the steps under Set Up a Device. If the Doorbell still doesn’t complete the setup, please give our support team a call at one of the numbers available here. You can also get in touch with our support team on Facebook @Ring.