How to reset ring doorbell pro

I bought a ring pro (v1) almost 3 years ago, but it was never even unboxed until a few weeks ago when we got an electrician to install. However it completely fails to work. We have verified that the supplied transformer supplies 24v correctly. It worked perfectly at first, went through setup, connected to WiFi first time then did a firmware update and has never worked properly since. We managed at one point to get a few images again for a few mins 2 weeks later when the electrician was back. I’m left with a device with a pulsing white light after it updates. I’ve tried various factory reset procedures (side button for 30s) but nothing resets it properly. It resets but it never goes back to the initial state where I can connect to WiFi. It is right next to the router now btw, and if I press the button it plays a ringing sound so seems to be getting enough power (also verified with a multimeter). Is there anything I can do?
Unfortunately support is only available by phone which I can not use :frowning:

Here’s the instructions for resetting (towards the bottom).
How to completely reset your Ring Video Doorbell – Ring Help