HEVC issues

I am using Firefox current version on Windows 10 Pro 64-bit…
Everything ran fine until today; now the Ring page says “I cannot display any of your videos, because your browser does not support HEVC”… then I clicked a button to switch to Legacy mode, but had to delete all my old videos because it would not play them.

I have checked Firefox (64-bit version 109.0), and HEVC support is enabled… So what is going on??
How do I get Ring to work with my modern, properly-configured browser?? And how do I turn of Legacy mode to get HEVC support, which my browser does support ?!?!

1 Like

Yep, looks like Ring broke something with HEVC, I have the same issues - all browser up to date as will as the Amazon Alexa app and Echo Show. All worked perfectly a few days ago.

I had 1 camera do the something. After playing around I did a live view on the PC and it switched it back to normal.

I was having the same issue. I tried on a windows 10 pc using Firefox and Chrome. I tried Safari and Chrome on a ipad (all using the most current version of said browsers)… All have the same issue on 1 out of 9 cameras at my location.

With the exception of a doorbell camera, the rest are stick up cameras (gen 3) with updated firmware.

After calling support, we tried:

  • rebooting the camera and wifi network.
  • clearing the cache/cookies on the browsers.
  • logging in using cellular network instead of wifi.

It doesn’t explain the problem or why it only was affecting 1 camera but as a workaround we turned on the legacy mode for that one camera.

If you’re managing a location with shared users, note this change can only be done from the owner/primary account. This could have saved me some time as I was logged in from a shared account.

That got that camera back up for me. Hope that helps someone…

Hi neighbors. I was able to find this post where others are experiencing the same concern. There is a marked solution to that post as well.

What is the solution to viewing videos in your event history that are in HVEC. Legacy mode does reverse apply.

There is no Legacy Mode in the App.
Why is this affecting some cameras and not others, even when they are on the same firmware version?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.