Hardwired classic Ring; existing doorbell not working and battery not charging.

Please help; I am at my wits end. Every time I call ring support I get a different answer. My HARDWIRED Ring is working; however the existing doorbell doesn’t work and the battery is loosing it’s charge (app says it is in battery mode.) Every time I call Ring support I get a different answer and they almost always want to upsell me something. My existing doorbell is mechanical with a transformer. Everyone else in my neighborhood (fairly newer homes 2004) just followed the set-up instructions; plugged theirs in and all was well. I almost think mine may be defective and perhaps was a returned item, as their was no baggie or protective film on the unit itself and there were tiny scratches near the security screws.

I found a tip on another site which told us to check to make sure the mounting plate is not screwed on too tight (as it may bow and not make a good connection) it also said to look and see if there was any residual adhesive on the contacts (making for a poor connection.) Neither of these helped me; maybe they will help you.

I’m having the same problem. I removed the mounting plate from the wall and reconnected the doorbell to it with the wires connected (supplying 20v) but it didn’t change a thing. From everything I’ve read, it looks like we’ve all purchased an inferior product.

Thanks for affirming I am not the only one.

I installed a 20 volt transformer on my ring two device a few months ago, and all work okay with no problem at all. But now a after it was working ok for months it stop working for no reason. I replaced the transformer even though the first one I installed was working and putting out 20 volts. But even with the new transformer it would not keep the ring device charged. Also when I first installed the transformer, on my app under health, it would say (hardwire) instead of (battery), it never went back to hardwire.

If you or any finds a resolution to this problem please post it, because I’m not getting anywhere with my research.


I also have a similar issue. After spending over 2 frustrating hours on my front porch in 30 deg weather trying to install my ring video doorbell, I have given up since it’s getting dark outside. I got mine all set up inside and mounted in place of my regular doorbell. It worked but wouldn’t activate the inside doorbell. I removed the mounting bracket and just let it hang there. I got it to work about 3 times. One thing I noticed is that it only works when the ring around the pushbutton is glowing white. When I push the button it then has a blue circulating ring around it and the inside bell works. It was very intermittent after that. Occasionally when removing and remounting it I would accidentally press on the back and the ring would glow white for a few seconds and then go dark. Bad contacts? FRUSTRATING!

Hi Guys (Frusty and Vic the Wolf and whomever else might look at this)

As if by magic; I did nothing (as my fridge went out on Monday so I have been concentrating on that.) My Ring Original Classic Doorbell is working correctly on it’s own. I noticed when I went out today (Thursday afternoon ) that the white ring on the doorbell was working (It hadn’t previously unless it was spooling when I was doing the initial setup by pressing the orange button) so when I came home I wanted to see how much battery I had left since mine had been in battery mode (since Saturday when I set it up) and I assumed it would be out of battery by Friday. It was in “hardwired” mode. I then tried the doorbell, and it worked inside the house too. Maybe it just takes a few days to kick-in to the hardwired mode, especially since so many folks probably received these for Christmas and are trying to set them up.

On a side note; a couple of different times since Monday I could not load the app or the motion detection screen, so I went out and rang the bell; which re-set the app to a functioning mode again. Maybe ringing your own bell is the answer to more than just app problems. I did not notice if the white light was on before ringing the bell to reset my app; as I just reached around the edge of the door to ring.

Best of luck to all you hardy souls trying to get you Ring doorbell working. From all the posts I’ve seen, there were too many people with too many problems. I returned mine to Amazon today for a refund. My son has the Nest doorbell and he’s very happy with it so I’ll give it a shot.

OK I am going to try the cg101 approach and remount my ring again. Did you wave a rubber chicken over it or use a special mystical chant to get it working? I’ll try again, however, this time I put a small piece of 1/4" plywood behind the mount to act as a stiffener as I suspected that there may have been some flex in the plastic mount and causing intermittent contact. So far so good. I’ll keep you posted. By the way does anyone know what the significance of the white light around the pushbutton is? I can’t find anything in the so-called manual.

Good luck , no chant or rubber chicken…lol! I did absolutely nothing (other than view a few events and ring my own bell to re-set the malfuncioning app) for those few days. The white light tells us it is hardwired. When mine was in battery mode it was not white; it had no color at all, until you rang it; then it was the blue swirling circle. When the white light swirls it is being reset/resynched by the orange button on the back.

OK, here’s the latest update. I finally got the doorbell to reliably ring the internal ding-dong. As I suspected, the piece of plywood behind the mount helped. I was able to ring it dozens of times yesterday afternoon and this morning. It is ABSOLUTELY necessary to screw the plastic mount to a completely flat hard surface. If it’s not perfectly flat the mount flexes and the doorbell doesn’t make a reliable contact. So far so good.

However, I went a way this afternoon for a few hours and when I returned I found the camera wasn’t being triggered with motion. I tapped the “ring” icon for the app on my phone and it took me to a screen that wanted me to login. When I did log into my account I was told I had to set up a device. There was no doorbell to be found. It was there on my wife’s tablet that I set up to share but not on my phone and it would still ring the ding-dong inside. Looks like I may have to set up the device again! Arrrgghh! On to chapter 2 of fun with RING.

Good to hear the plywood worked; sorry to hear about your app problems though; also glad to hear your wife’s app was still working. I had some app problems too; I almost feel like some of are destined to jump through a few hoops before all of the kinks are ironed out. If it happens again try the “ring your own bell trick” as I did (for my entirely different app problem) as it may save you reinstalling the app…