Guest Codes Not Working

I’m new to Ring, and just installed a system in a house we’re getting ready to sell. My problem is that I’ve set up guest codes for the real estate agent and a couple of other people, but I can’t get the system to respond to the guest’s access codes. I’ve done everything I can think of, including setting schedules for the guests (all day and all seven days).

When I try to test the system using one of the guest codes, the Ring app reports the incident as “PIN Rejected”. Did I miss something, or is there something wrong with my system? Thanks a lot for your input!

Mike

Hi @MichaelCfffg! As long as you’ve created and successfully saved a guest code, and the guest is entering this code during the scheduled times, their PIN should work. Keep in mind that, at this time, Guest User schedules only apply to the Alarm Keypad. They do not apply to smart locks. For example, if your Guest User has an access code which works in your smart lock and uses the code in the lock outside of the scheduled hours, they will be able to get inside your home but would not be able to disarm the Alarm, potentially resulting in a false Alarm.

Please ensure the Alarm Keypad is being used with the correct Guest User code, during the desired times, if a schedule was set. Feel free to check out our help center article for more information on Guest User access. I hope this helps! :slight_smile:

Thanks for the quick response to my problem, Marley. From what I can tell I have correctly entered and saved my guests and their entry codes, but the system still won’t arm or disarm using their guest codes, and shows a “PIN Rejected” log entry. So now what?

We don’t have a smart lock on the house, just the basic 10-piece security system. The keypad is the only arming/disarming device in our system.

Thinking the problem may somehow be related to my cell phone, I have re-entered one of the guest codes using my laptop, but won’t be able to test the system again until probably Tuesday. We’re getting ready to go out of town right now.

I want to sign up for the monitoring service, but not until this is all working properly.

Thanks again!

Of course, @MichaelCfffg! That actually is precisely the next best step. Using another device, or even removing and reinstalling the Ring app on your mobile device, can help factor out certain variables. Depending on the mobile device being used, please ensure that vpn is disabled and that there are no apps that might conflict with the Ring app. Feel free to let us know how that goes. :slight_smile:

Hi Marley;

I re-entered my guest codes from my laptop computer, but they still aren’t being accepted by the system. I’m getting very frustrated.

I tried to log onto the Ring website to try to get some help from my cell phone, but the app won’t accept the verification code, saying it’s the wrong code or that it’s expired. I’m entering it in less than a minute, and the code is supposed to last for 10 minutes. It’s not the wrong code because I’m doing a direct Copy & Paste from the email. Why can’t the system just ask me for my mother’s maiden name, or something like that, like every other on-line security plan does.

I finally gave up on trying to log in, and looked for a phone number without logging in. I did find one, but when I tried to call just to ask a couple of simple questions, there was yet another layer of security asking me to both log into the website and then still get another code of some sort to continue.

I’ve been all over the Customer Service Help maze, but nothing there addresses the problem I’m having, and there is no way to escape to a live representative. I am really frustrated with this system and the lack of real customer support. I don’t know if the problem I’m having is a hardware problem, a software problem, or a user problem, and so far I’m not getting any closer to a solution. This is Ring’s responsibility, and they’re not resolving it. I hope you can point me to a way of getting this resolved. Thank you once again for at least communicating with me!

Sorry to hear about this experience, @MichaelCfffg. I can assure you this is intended to be quick and easy, as well as secure. Although it sounds like you are doing everything correctly for the login verification, take a look at our Community post about account security to see if any tips might be of assistance.

After seeing all the steps you’ve taken, it is certainly odd that guest codes are not working and your verification code is not working as intended. This may require a more in-depth look from our support team. As we value your security and privacy, there will be a verification option when calling in. This is to add a layer of security and convenience, but is not mandatory, and you should be able to reach our support team either way.

For the best method in reaching our neighbor support experts, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to update us on any solution you find, as it may help other neighbors in the Community! :slight_smile:

Hi Marley;

I’m much happier today. I’ve solved a couple of issues, including the one I initially posted about, and my system is up and running now as it should - with all guest codes working.

The resolution to my initial problem, the guest codes not working, was resolved by plugging my laptop directly into the Base Station using a cable. Logging in to the system while directly connected to it, surprisingly enough, did not require an emailed verification code. When I re-entered the guest codes with my laptop directly connected to the Base Station got them all working correctly except one. That was the second problem I had to resolve.

After trying several different number sequences, it was apparent that something else was wrong. Having known the neighbors for many years, but not knowing their last name, I had entered them in as “John and Mary” (not their real names), and using three words was the only difference from the rest of the guests in the system. I deleted “John and Mary”, and set them up again as “John Mary”, which resolved that issue.

So apparently the system won’t work correctly with a three-word name. That should be corrected, and the User’s Manual should be edited to address using the included cable to connect directly to the Base Station if programming problems are encountered.

Thanks again for your input, and I’m glad that I’ve got this finally straightened out.