Got the basic protection plan but my ring won’t record!

So I just got the basic protection plan for my ring doorbell and I noticed it is not recording anything!! It keeps telling me to upgrade or get a protection plan, but I already got it! Do I need to update my device? Does it take a while for it to register? Help and answers are much appreciated! Thank you

I am also here to ask the same question. I had one device with ring protect and just added ring protect to another but I am still not able to view recordings.
I even cancelled both and resubscribed but still will not alloow me to review records made after subscribing. I’m wondering if there is a delay? My account shows that I’m subscribed?

I just signed up for ring protect plus and am in the same boat. Says I am subscribed, but when I go to see history it says I need a subscription

I added the basic protection this morning, and I’m in the same boat. And I can’t get ahold of anyone for customer service. Has anyone figured it out?

Hello,
Pleased to see your question, I think I have same question and can’t able to find any solution on google so please help me as possible.

MyAARPMedicare

Hey neighbors. Thank you for bringing this to our attention. Since this concern involves your specific account information, this would be best solved by reaching out to our support team so they can take a closer look. Please give our support team a call at one of the numbers available here. Feel free to let us know how this goes for you!