Gen2 Not finding new wifi

I have done everything, my wifi has two connections, one for 5ghz and the other for 2.4ghz, I restarted my phone, the video doorbell and router many times and nothing worked. I turned off my phone data, I made my wifi 2.4ghz only, it doesn’t even see my neighbors wifi which it has in the past. The app doesn’t show any networks. Please help.

1 Like

I am having exactly the same issue. recently switched Internet provider, tried to connect to new router and doesn’t show my network or any networks for that matter. All my cameras are down and doorbell the same. Please assist ASAP. There is not any issues with connectivity as I have several devices connected and working. Factory reset has been performed on all devices, cache cleared and app reinstalled. When using app, my WiFi is on then as soon as it prompts the ‘select network for ring doorbell to use’ it goes off. All devices are connected on 2.4ghz

1 Like

I am having the same issue! Has anyone figured out a solution for this problem?

Hi neighbors. First, ensure your Ring app is fully updated and, if possible, bring your Doorbell close to the router to attempt the setup process. Then review the troubleshooting information here for setup failures. Trying the setup process on a different mobile phone and resetting your Doorbell by holding down the setup button for 20 seconds are usually the best steps to try first.

If this issue persists, one last thing to check is if the ports and protocols used by Ring devices are open on our router. Should that still not resolve the issue, please give our support team a call at one of the numbers available here for more in-depth assistance. If you are outside of the US, please visit here to see how to contact support.