Gen2 Doorbell stuck updating

Ring doorbell (Gen2) has worked perfectly for about 10 months, then suddenly appears to be stuck installing an update. This has been constant for about the last 4 days, still saying Doorbell is installing an update…this may take 15 mins…still not updated after hours.

I’ve tried hard resetting the doorbell a number of times, as soon as its set-up, it starts to install an update, then gets stuck again. I’ve tried different wifi networks in the house, still nothing. Deleted and re-loaded the app, then repeated the re-setting process. still nothing.

The doorbell appears to go through a sequence of lights…faster flashing white ring, nothing, flashing blue ring, solid blue ring then flashing blue…on the second it allows me to press the button on the front on the doorbell (as if someone has rung the doorbell) then all appears to work ok for a short while, then goes back downloading an update (same sequence of lights).

Every time I change wifi connection, it appears to want to download an update.

Getting frustrated

Hi @rh2801. You have tried all the basic troubleshooting steps I would have recommended for your concern. The next best step is to contact our support team for further assistance. Give our support team a call at one of the numbers available here.