Gen 2 doorbell just stopped working

My Gen 2 doorbell just stopped working randomly on the 29th April. i did as per the troubleshooting to try to reconnect but no joy. I then deleted the doorbell and removed it from my account and tried to reinstall from scratch. However when going through the set up the app cannot see my WIFI.
i have tried to enter the WIFI network and password manually but it still cannot connect. Other devices are happily connected to the same WIFI with no issues.
I have also checked and my router is configured to 2.4/5 and 6GHZ
i have no idea what to try next.

Hi @Hanx010. Try creating a guest network that is only 2.4GHz, as the Doorbell (2nd generation) is only compatible with 2.4GHz networks. Dual-band networks can sometimes cause issues, so separating the bands and having a guest network on 2.4GHz only should help you get your Doorbell reconnected to your wifi network.

If that doesn’t do the trick, you can follow up with our support team at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.