From Android Ring App "LINKED DEVICES" cant link or unlink ALL ring products "camera, door bell

I have all wired ring products from below.

2 flood light cam, 4 spot light cam, 2 stick up cam, door bell, alarm, smart lights.

i didnt really use the Linked Devices feature until i got smart lights, i wanted to link to turn on lights at certain motion from my cam.

this is where i noticed the problmes. It wont let me link or unlink ring cams and lights and i get this “something went wrong” please see my screen shot attached.

I called and left talk with Ring customer service yesterday and left my email, they to check my email for any response.

Anyone having this kind of problems? any fix?


Hey @rog7254. Could you try adjusting these settings with your wifi turned off, and just using mobile data to change these settings? Also, try changing the settings with each individual device under the Main Menu > Devices > Click on device at a time > Linked Devices. See if changing the settings in each camera to link to the Smart Lights works instead! :slight_smile:

followed your instruction.

Still same problem. Nothing changes.

can i email you the video, cant attach.

@rog7254 Yep! If you cannot compress it into a ZIP file and attach it here, please feel free to email me at :slight_smile:

@rog7254 Thank you for emailing me that video and letting me attach it here for other neighbors to reference.

After taking a look into your video, I noticed a few things. While you continuously got this error message, the settings looked like they saved for your Front Drive Way Floodlight Cam! If you look back into the recording, you turn on motion detection and turning on the lights when an event happened for your Lawn Camera, and while the app said there was an error, when you later went back, it looked like the settings were linked to how you were trying to save it. For this reason, I recommend doing this process for all devices as you have, and see if by the time you have updated all of them, that the settings still exist! It seems they may be saving despite the error message you get.

In the event they are still not saving, please try removing the Ring app from your phone, rebooting your phone, and then reinstall the app. From there, see if the settings can save and if it still doesn’t save the settings, or the app reinstall does not help, please let me know!

I will also post this same reply in the other thread we were in, just in case this helps other neighbors that may run into this!

unstailled the ring app, rebooted phone.

same problem occurres.

1 Like

@rog7254 Thanks for getting back to me! Although you were trying to save the settings and you got the error, when you later visited the same settings, was what you were trying to save, showing as the proper settings now? I wanted to establish if it was doing as your screen recording showed, or if maybe that was a one time thing.

All in all, since you still cannot get this saved, I recommend giving our support team a call here. Feel free to let me know how this goes!

I am having similar issues as of 5-9-20. When linking other devices to a specific cam, the settings aren’t remembered at times and the popup shows “retry”. If you exit COMPLETELY out of the app, then make changes, they will be remembered, HOWEVER, you MUST exit COMPLETELY out of the app after adding linked devices to a specific device and do this for each one you want to setup.

I’ve also noticed when you go in to the linked devices setting in the app to just check your settings, those settings will appear to be carried over to the next device you look at, but if you close the app completely when you reopen, the correct settings will be shown. But again, you must close completely out of the app each time you do anything with the linked devices area, or you won’t get true display of linked devices. RING should be working on getting this fixed, as it’s clearly an issue.

1 Like

Hey neighbors! If you are still getting this error message, it looks like this matter is being investigated by my advanced support team. They will work diligently to get this bug in the app fixed. I will make sure to update you all in this thread once this matter is resolved. :slight_smile: