Floodlight won't reset, light stays on, can't connect wifi.

One of my floodlights has lost the wifi-connection two days ago, lights came on and now stay on all day and night, and it will not enter setup mode. I tried just pushing the button, and nothing happens. I tried holding the button down for 30 seconds to reset it, and nothing. Just the spotlights staying on.

I opened it up, disconnected the wires and reconnected it. The spotlights turned right back on, but i still can’t set it up.
i didn’t have any problem setting up the other 3 cameras. What should I do?

1 Like

Hey @bentan_2001. At this time, if your Floodlight Camera will not reconnect or complete a setup, please attempt the following:

  • Ensure there is no debris in the install location and wiring that could be preventing the device from a stable connection.
  • Press the setup button on the Cam and complete the setup in the Ring app.
  • If lights flash and setup is not completing in the app, please remove and reinstall the Ring app on your mobile device, disable VPN, and have your wifi router close to your Camera (if possible, may not be or applicable to you).
  • If lights do not indicate setup mode on the camera, or setup is not completing, perform a reset on the Camera by holding the setup button for 20 seconds.

If the above steps do not result in successful setup or operation, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

I am having the exact same issue. The floodlights stay on all the time and the camera will not respond to set up. Reading the code and/or pressing and releasing the button on top of camera will not trigger the camera to flash. Can not connect camera to WiFi. I have another floodlight wired to same switch, lights stay on all the time, but camera is connected to app and WiFi, and camera works. Lights never turn off.

1 Like

Having the same issue with both of mine… I’ve tried everything and been working on this for over a week, just haven’t had time to call in for help

I’m having the exact same problem with a floodlight I just installed today. Cant connect to it through ring app, it’s stuck on, and I can’t reset it. Ugh! Any help?!

Yeah i called in and troubleshooted with two guys yesterday, they were great, very helpful & we tried everything, but to no avail unfortunately . Anyhow, my best guess is something happened during setup, maybe a surge or interference, idk but they’re sending me replacement so I’m gonna try It again. Hoping for better luck this time. Cheers

1 Like