Floodlight Wired Pro Camera - Strobing

Hi all, reaching out to hopefully find some help.

Over the last 2 months my wired Floodlight Wired Pro Camera has started strobing everytime we have a power outage. The strobing continues until the device is powered down and then turned back on again. Fun part is the light then strobes into our neighbours properties (multiple) and they’ve complained to us. I’ve had the device for a reasonable amount of time (longer than a year or two) and no issues till recently.

I’m on the protect plus plan. I’ve contacted ring and they’ve said I need to show them a video of the camera strobing before they’ll believe me. Unsure why they can’t check the device to see if the lights were strobing?

Has anyone had any luck with this? I’ve noticed numerous topics with this issue (my apologies about raising another) but clearly this is an issue, that keeps occuring and we should be able to get some help if we’re on the right plan?

Thanks to anyone that can help me out.

Hi @user71342. I’m sorry to hear that you are having this experience. Please send us a private message on Facebook or Twitter @Ring for assistance with this. If your device is not functioning the way it should, we want to take care of it for you.

Hi Tom_Ring, thanks for the reply.

I’m sorry I don’t use Facebook or Twitter, how else can I contact you? I’ve now been able to get footage of the strobbing, so need to know where to send this please to get our camera replaced.

Thanks
Chris

Hi @user71342. If you don’t want to create an account on one of those platforms, give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Hi @Tom_Ring, I’ve contacted support but they’ve said I needed to reboot the device (which I’ve done) and then the issue needs to happen again.

The support person couldn’t figure out how I can send a video to Ring, are you able to help? The upload a file URL I was sent, doesn’t take video’s and I was asked to reply to noreplay@cs.ring.com with the video, but that email just gets rejected.

Any ideas?

Thanks
Chris

Hi @user71342. I apologize, but the Ring Community is a public forum, so we do not have access to device or account information. I would suggest following back up with support and letting them know you have contacted them about this issue already.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.